Grub died after timeshift backup

Dear all,

unfortunately i am experiencing my first roadblock in endeavour (but i guess its more a linux or grub thing, not eos), as my system is no longer booting by itself. Here is what happened:

After upgrading with yay my desktop (cinnamon) was having problems with showing the desktop and the panel at the same time. No problem i thought, go back with the timeshift backup and wait a few days until this gets resolved upstream. Therefore i did a rollback to “before latest update”, including the recommended option of restoring grub with timeshift. Then - only grub rescue prompt and no way to get things back to working. When using ventoy and refind or supergrub2 i can start my system without problems. It seems it is the same case as in this thread over there at manjaro.

I tried the following:

  1. Rescue grub and reinstalling grub like here (german)
  2. Reinstalling grub for EFI-systems
  3. Install rEFInd, worked also with no error but again only grub rescue
  4. Reinstalling grub via yay and/or pacman

Everything leads to the same result - only grub-rescue on startup, rebooting from stick and then using the right grub on disc will start system as usual.
So i suspect that something went wrong with timeshift backup restore, but i dont know what. Also there seems to be a problem with “before grub” as when starting grub from stick everything works fine.

I used the eos-log-tool, the results can be found here.

Burschi500

If you reinstalled grub and are still getting that prompt, it would be interesting to know what your efi boot order looks like.

Can you share the output of these commands:

sudo efibootmgr -v
lsblk -o name,type,fstype,size,uuid,partuuid

You can run those from the live ISO.

Hi dalto,

here you go. Acutally i am using my computer normally, since i can use the old grub entries from my disk. It just doesnt work on its own…

Additionally i recognized that the partition with efi was marked msftdata and not esp, boot. I changed that also but with no change in the above mentioned behaviour.

Try this:

sudo efibootmgr -o 0000,0004,0003,0001

Nope, the usual result (sorry for the bad “sceenshot”):

Hopefully you aren’t using grub-customizer?

Actually i do/did, whats the conclusion here?

Remove it and reinstall grub from arch-chroot on live ISO.

Edit: It’s evil! :rofl:

Ok, why from arch-chroot? Wouldnt my current installation suffice this?

You cant reinstall grub that way.

Edit: https://discovery.endeavouros.com/system-rescue/arch-chroot-for-efi-uefi-systems/2021/03/

Oh, ok. I just did that with pacman with no complaint, why is it so?

Ah…you should be able to.

Re-installing grub has two different meanings in this case.

You can re-install the package grub but that won’t do much.

The more important point is to reinstall grub with grub-install and then grub-mkconfig

I was under the understanding you can’t fix grub that way by just reinstalling it with pacman. But what do i know?

That is true but that has nothing to do with booting off the ISO and using arch-chroot. Are we having the same conversation?

I don’t know. I thought that’s the way it needed to be done to fix a broken grub problem. Reinstall it and update grub with the command as you alluded to. Maybe It’s not needed and grub update command wasn’t used before?

You don’t need to boot off an ISO and arch-chroot unless you can’t boot into your system. If you have a way to get into your system, you can do it from there.

I stand corrected then. :shushing_face:

In my first post, under 2), it is described to do grub-install and so on, but that didnt work. Just for clarity (i hope…) i am using my system as normal since i can boot it with the help of the refind or supergrub2 images. With these images i can launch my old grub entries and get a working system, but when starting the system i dont get the grub menu, just the grub rescue promt…

what do you mean by “old grub entries”?