Grub.d 40_custom

hello all,
cassini-neo (with systemd-boot) was installed next to artemis (with grub)
now I’m looking for the right menuentry in grub-d 40_custom to list cassini in the grub menu.
did several trials but no succesfull.
would be grateful for tips on the solution :man_detective:

Try something like this:

menuentry "systemdboot" {
	insmod fat
	insmod chain
	search --no-floppy --set=root --file /EFI/systemd/systemd-bootx64.efi
	chainloader /EFI/systemd/systemd-bootx64.efi

unfortunately doesn’t be succesfull :thinking:

after reboot in grubmenu appears the new entry “systemdboot”
but when you click on it there appears

Reboot Into Firmware Interface


EDIT: in Firmware Interface / BOOT ORDER there is the choice
artemis / Linux Boot Manager
but that’s not what I’m looking for

What is the output of find /boot/efi from Artemis?


Hmm…maybe you have more than one ESP?

What does lsblk -o name,type,fstype,size,mountpoint show?

only one

sda    disk         40,8G 
├─sda1 part vfat     300M /boot/efi
├─sda2 part ext4    19,7G /
└─sda3 part ext4    20,8G 
sr0    rom  iso9660  1,9G /run/media/reborn/ROS_202211

Your systemd-boot install on that efi partition has no entries. That is why the menu is empty.

You grub custom entry is working, but there is nothing there to do.

I also don’t see an Artemis install there. I see a grub RebornOS and systemd-boot but it doesn’t look like a Cassini systemd-boot install.

What is the contents of /boot/efi/loader/loader.conf

oh sorry ! I see now, I was wrong.
I run a Vbox ( in artemis) and therein is cassini next to reborn. sorry, I forgot


#timeout 3
#console-mode keep

OK, so what are the contents of the above mentioned file?

That file isn’t from a Cassini systemd-boot install. Also, you have a 300MB ESP. Cassini won’t install systemd-boot into a partition that size.

You also have no kernels or boot images in your ESP.

that’s right - it is from the grub booted OS

That is a systemd-boot file. Grub would never create that. Can you provide the order of events here?

I’II switch to cassiniOS and have a look there

it seems to be a big mess !

ok, there is a rebornOS in Vbox - installed with GRUB-Bootloader
recently I tried to create a dualboot with cassini.
accidently i choose systemd-boot during the installation
that’s all

That systemd-boot did not come from EOS. Are you sure it isn’t a different VM? I am not sure that VM has EOS on it unless it is installed in legacy mode. Can you boot into the EOS on that VM?

well, I could boot into cassini BEFORE I followed your advice in answer #1
after that it stucks in the firmware interface…
I better stop here and delete everything - start a new trial with new installs :thinking:

that fact I don’t understand
the reborn run well since a lot of weeks (in grub mode)
the cassini is installed in systemd-boot wrongly…
there is nothing more I know except several trials of mine to create a menuentryscript in 40_custom ( have some experience with that in debian)
But it did not work, therefor my topic here

I don’t know exactly what happened but the output you showed me isn’t from a Cassini systemd-boot install. That looking like someone ran the command bootctl install but did nothing else. A Cassini systemd-boot install would not look like that at all.

1 Like

yes, I do believe that !
But not know what happend

Thank you for your time and engagement to give some help to me !

1 Like