GRUB booting to terminal

GRUB is booting to terminal for me without fail. I am on a windows/Endeavouros dualboot with kernel version 5.10.11-arch1-1.

I have followed the instructions here to boot to, on my system, (hd0,gpt2)/boot/grub where after I run sudo update-grub. This hasn’t fixed the problem, what should I do?

Welcome at the Forum :enos_flag:

will give you command not found if you do not install a wrapper…
On arch the command is:
sudo grub-mkconfig -o /boot/grub/grub.cfg
if that does not help:

I have installed the wrapper. I suppose I am looking for Repair GRUB EFI/UEFI system?

issue can be different stuff… do you get exactly that grub rescue shell? or a login prompt what says EndeavourOS kernel and ask for username?

Upon booting I get a screen like this

, pic lifted from google.

it could be also a windows update that screwed your linux install, what is reported to happen in some cases…
It should give you some warnings or/and errors when updating grub.cfg reinstalling grub structure like so:
sudo grub-mkconfig -o /boot/grub/grub.cfg
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub
from booting with hacking grub startup like you done before or from chrooting into installed system like EOS wiki say could help, but there must be a reason why this happens at all.

1 Like

means not from your system? but the same output? or similar only? but you get that grub> prompt?

and if you go for chrooting make sure if you run a legacy BIOS system or reacent UEFI boot system!

Welcome! :smile:

You are using Ubuntu grub?

He grabbed it from google search results

Sorry for disappearing, think we’re on slightly different timezones.

Here is the results of running the grub-mkconfig

[morten@endeavour ~]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
[sudo] password for morten: 
Generating grub configuration file ...
Found theme: /boot/grub/themes/EndeavourOS/theme.txt
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot: initramfs-linux-fallback.img
Found Windows Boot Manager on /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
done

and the result of grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub

[morten@endeavour ~]$ sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub
Installing for x86_64-efi platform.
Installation finished. No error reported.
[morten@endeavour ~]$ 

both of which I have attempted already, I’m not so familiar with arch installs but it doesn’t look as though anything went wrong from these msgs AFAIK.

And this error happened since installing endeav, so it’s not as if I have had time to make a windows update in the meanwhile.

Sorry I just lifted an image from google here is what my computer actually boots to

and after

set prefix=(hd0,gpt2)/boot/grub
set root=(hd0,gpt2)
insmod linux
insmod normal
normal

I see

where AFAIK (hd0,gpt2) corresponds to my arch partition.

What does

efibootmgr -v

say?

[morten@endeavour ~]$ efibootmgr -v
BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 0002,0001,0000,0016,0017,0018,0019,001A,001B
Boot0000* Windows Boot Manager	HD(1,GPT,a81c3d6d-f2e2-4afb-a30f-910107a4854a,0x800,0x100000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0001* ubuntu	HD(1,GPT,a81c3d6d-f2e2-4afb-a30f-910107a4854a,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0002* EndeavourOS-grub	HD(1,GPT,a81c3d6d-f2e2-4afb-a30f-910107a4854a,0x800,0x100000)/File(\EFI\EndeavourOS-grub\grubx64.efi)
Boot0010  Setup	FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0011  Boot Menu	FvFile(126a762d-5758-4fca-8531-201a7f57f850)
Boot0012  Diagnostic Splash Screen	FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)
Boot0013  Lenovo Diagnostics	FvFile(3f7e615b-0d45-4f80-88dc-26b234958560)
Boot0014  Startup Interrupt Menu	FvFile(f46ee6f4-4785-43a3-923d-7f786c3c8479)
Boot0015  Rescue and Recovery	FvFile(665d3f60-ad3e-4cad-8e26-db46eee9f1b5)
Boot0016* USB CD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
Boot0017* USB FDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
Boot0018* NVMe0	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,001c199932d94c4eae9aa0b6e98eb8a400)
Boot0019* ATA HDD0	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f600)
Boot001A* USB HDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,33e821aaaf33bc4789bd419f88c50803)
Boot001B* PCI LAN	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
Boot001C  Regulatory Information	FvFile(e4a83242-deee-f12e-15ff-0102036cc3ce)
[morten@endeavour ~]$

I can see there’s still an ubuntu entry, maybe this is causing some problems?

It might but yet the EnOS’ bootloader is shown to be the first in boot order. You could try removing Ubuntu’s and see if it will make any change.

How do I remove an entry?

sudo efibootmgr -b **bootnum** -B

In this case:

sudo efibootmgr -b 0001 -B

for removing Ubuntu’s. Reboot after that and hopefully you get into EnOS’ grub.

2 Likes

I have always a very different timezone…

:enos_flag:

1 Like

Tried rebooting, same problem as before where I am forced into a grub terminal.

You could try to rebuild your whole Grub environment. Here are the instructions:

If that wouldn’t work, I am afraid I don’t know what might be going on.