Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update

I had refind unbootable, but that was a decade ago and me running Linux on Mac :scream:

Please share how you downgraded or post a link on it.
I am seeing mixed resuls on dongrading grub.


Look at my pinned post. It covers all the scenarios with the instructions

1 Like

This was so much fun. I went to visit my mum today, I updated her laptop, like I do every other week, shut it down and went home. Then I updated my computer at home, and it didn’t boot. Not a big problem, I booted a live image, chrooted, downgraded grub. Now it booted fine, and I went to this forum to find out that it’s not necessary to downgrade it, so I updated it again, fixed it and the whole thing is over. Right?

Then it dawned on me that the same thing probably happened to my mum’s laptop, which I updated earlier, and that the poor woman is now without a computer, as she can’t possibly fix it herself. So I called her, asked her to turn it on, and it didn’t boot, of course. Damn! So I went back to her flat, fixed it, and went home again. Lost about 5 hours…


Please post link.

How can you miss it? It’s literally on every page of the forum :rofl:


ooooo. glad I was late to this party!


I followed that post to the letter. It did not work.

How did you downgrade grub? That is not in the post or in discovery.

You don’t need to downgrade grub. Although, you can if you want to, but you have to chroot anyway to do that…

You only need to run those two commands (after you chroot of course), which could be slightly different depending on your system.

No need to downgrade grub. Have you read the instructions carefully?

No i have memorized it.
Those instructions do NOT result in booting grub on my system.

Have you used grub customizer in the past?

I guess the ship has sunk then. Man the lifeboats…all hands on deck!


Well, then boot the live image and chroot into the installed system again, like you did before, but now instead of running those two commands, just run

downgrade grub

and then

grub-mkconfig -o /boot/grub/grub.cfg

Though, it shouldn’t be necessary to do that.


Everything is default single :enos: boot, Btrfs, using default btrfs install and Dalto’s Brtfs assistant.

Interesting that you’re the first case it hasn’t worked. Can you repeat the instructions and post the output of the commands? We’ll take a look

Steps I took following this tutorial:

Your partition layout and device may differ
sudo mount -o subvol=@ /dev/sda2 /mnt
sudo mount -o subvol=@log /dev/sda2 /mnt/var/log
sudo mount -o subvol=@cache /dev/sda2 /mnt/var/cache
sudo mount -o subvol=@home /dev/sda2 /mnt/home

sudo mount /dev/sda1 /mnt/boot/efi

sudo arch-chroot /mnt

sudo downgrade grub

Chose the package: 2:2.06.r297.g0c6c1aff2-1


But note that we found a better way to solve this than downgrading grub, follows below:

Soon after this, I decided to try the method suggested by @joekamprad here in this post and it worked:

Boot into the liveusb, arch-chroot as per commands above, then run:

efibootmgr (to get the name to use in the next command, in my case it was endeavouros-2297, this is optional, you can use any name you want)
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=endeavouros-2297
sudo grub-mkconfig -o /boot/grub/grub.cfg

If you can’t boot after this and get the following error:

Loading kernel linux-zen …
452: out of range pointer: 0x89253020

Aborted. Press any key to exit.

You need to go into the BIOS and select the endeavourOS-2297 as your boot for the EnOS.

I can try it again .

Unfortunately I don’t know, I don’t have experience with RAID

1 Like

Hi Guys,

small question, has someone who has not updated grub yet tried this procedure already?

Note for people who haven’t updated their system and are looking to update

If you haven’t updated your system yet, follow these instructions:

  1. Update your system as usual
  2. Immediately after you update your system, install grub.
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub
  1. Now, you can reboot your system normally, and it should boot fine.

If so, what was the result?

Edit: I’ve been wondering if this grub problem occurs mainly on laptops or does it not matter laptop or desktop?