Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update

What should I do now?
i booted to liveusb and followed the instruction and rebuilt grub successfully.
It still boots to bios. Argh!!

It is btrfs and the snapshots are listed when i rebuilt grub.

What else can I try?

I can’t possibly read all the responses to this thread (maybe I should). This event may be a good example, or driving point, to possibly give users the option to select their preferred bootloader during the Endeavour OS install.

Grub can still be the default option of course, but I’ve seen users who would like to use systemd-boot (for example) and we even have detailed information on this website for switching from grub.

Why not be able to select your desired bootloader?

done that and its the same exactly issue…

1 Like

rebuilding grub.cfg will not solve the issue as it needs to reinstall the grub files into ESP so not grub-mkconfig is needed its grub-install what needs to be run as it is said in the pinned post also.

1 Like

On the one hand you are right, on the other hand it is not only a small bug, but it makes the whole system unusable for the time being. A condition that is unacceptable for a production system, no matter who the developers are. Then maybe there should be a warning on the homepage: Attention, for serious and reliable work only conditionally usable! SCNR

Yup, got bit by this one. Wound up using my live EOS ISO to arch-chroot in. First tried re-running grub-mkconfig but, that didn’t work. Then just restored from timeshift, got rebooted and back on this forum then found this was a known issue with the fix (thanks Dalto :slight_smile: ). Going to test it now, then I’m off to go swordfighting.

EDITED: to remove this assumption, was not correct.

1 Like

I followed it to the letter and still boots to Bios. What else can i try? I have an unbootable system.

@dalto I have the default btrfs setup with your btrfs assistant. No dual boot, just :enos: Should i be doing anything differently than the 2 docs joe published? I got no errors with arch-chroot.

How do i downgrade grub or boot to my last snapshot in cli?

Also on liveusb it does not recognize
loadkeys fr so its hard to find the symbols like pipe to troubleshoot.

You are absolutely right. Although I think that normal users who just use EOS have probably never heard of chroot (just as I read about arch-chroot for the first time today). How are they supposed to fix the problem if the computer won’t even boot?
But there is something good about it: I got to know refind, as well as arch-chroot, and we discovered how good this forum is here. Because that helped me enormously in solving the problem.

Just finished reinstalling. again. Note to self: check the forum BEFORE updating.

1 Like

Were you using grub customizer? Do you have a snapshot you could restore?

I also have BTRFS but with RAID0. Would I have to do some additional steps in order to mount properly?

In the thread on Reddit (r/archlinux), a number of people have reported that simply regenerating the init images with sudo mkinitcpio -P before rebooting works.


that is already done in :enos: using a hook. It’s clearly not a solution


I just tried running the grub-install command provided by Dalto. I got put into grub rescue mode on reboot with a “grub-debug-malloc” not found message. Back to the last timeshift for now because I’m heading out. I’ll check back after I return.

1 Like

What are steps to downgrade?

I have to install my girlfriend’s new computer this weekend (EOS KDE, so online installation with this broken grub update included.) I don’t know yet if the hardware of this machine will have the same problem. If so, I will have to install Manjaro again for her. I myself was lucky with my computer, it did not affect me.

Only that is not always possible with these many small updates. Besides: if everyone waits with the update, who is supposed to find out if the shit hits the fan …?

That sounds like a good plan. What should we do in the meantime?

I have not read this whole thread, so apologies if i am asking something that is being addressed. That is my next task.

I have followed the instructions and it still boots into bios. So what is n00b to do.

Like Lilo :laughing:

Maybe because one bootloader already gives enough headache to support, look at this thread… :wink:

Edit: like your username btw.

1 Like

Is rEFInd suited for single boot :enos: systems on default btrfs?
Sounds like it time to look for alternatives to grub.