Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update

Manjaro users are seeing this too:

I had a good poke around, and I can’t see anything either. A lot less Arch users are seeing this, which is weird.

1 Like

I did an arch-chroot on btrfs and downgraded.

[ricklinux@rick-ms7c37 ~]$ pacman -Qi grub
Name            : grub
Version         : 2:2.06.r297.g0c6c1aff2-1
Description     : GNU GRand Unified Bootloader (2)
Architecture    : x86_64
URL             : https://www.gnu.org/software/grub/
Licenses        : GPL3
Groups          : None
Provides        : grub-common  grub-bios  grub-emu  grub-efi-x86_64
Depends On      : sh  xz  gettext  device-mapper
Optional Deps   : freetype2: For grub-mkfont usage [installed]
                  fuse2: For grub-mount usage [installed]
                  dosfstools: For grub-mkrescue FAT FS and EFI support [installed]
                  lzop: For grub-mkrescue LZO support
                  efibootmgr: For grub-install EFI support [installed]
                  libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue [installed]
                  os-prober: To detect other OSes when generating grub.cfg in BIOS systems [installed]
                  mtools: For grub-mkrescue FAT FS support [installed]
Required By     : archiso  grub-tools  grub2-theme-endeavouros
Optional For    : None
Conflicts With  : grub-common  grub-bios  grub-emu  grub-efi-x86_64  grub-legacy
Replaces        : grub-common  grub-bios  grub-emu  grub-efi-x86_64
Installed Size  : 32.97 MiB
Packager        : Christian Hesse <eworm@archlinux.org>
Build Date      : Wed 17 Aug 2022 08:45:19 AM
Install Date    : Thu 25 Aug 2022 07:02:52 AM
Install Reason  : Explicitly installed
Install Script  : Yes
Validated By    : Signature
1 Like

Same here!
Though I am on BTRFS I thought that no matter what happens I will always have something to boot to!

1 Like

Months ago, when I installed BTRFS I asked how to chroot into it as it had been a long time since I had used it. @dalto kindly helped:

arch-chroot:

sudo mount  /dev/nvme1n1p2  /mnt -o subvol=@
sudo mount  /dev/nvme1n1p1  /mnt/boot/efi
sudo arch-chroot /mnt

Replace nvme1blah with your device ID. @limotux even with snapshots, you would have to chroot in to restore.

This is a good command to find basic disk info:

df -Th | grep "^/dev"
/dev/nvme1n1p2 btrfs     1.9T  581G  1.3T  32% /
/dev/nvme1n1p2 btrfs     1.9T  581G  1.3T  32% /var/cache
/dev/nvme1n1p2 btrfs     1.9T  581G  1.3T  32% /var/log
/dev/nvme1n1p2 btrfs     1.9T  581G  1.3T  32% /home
/dev/nvme1n1p1 vfat      300M  3.2M  297M   2% /boot/efi
1 Like

This is enormously helpful, thank you. Two laptops back up and running in no time. :+1:

yea same for me on legacy Bios devices…

For uefi systems i see that it is needed to reinstall the grub files into esp (grub-install) in addition to regenerating grub.cfg (not sure if it is needed at all)

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Name_it_what_you_want

6 Likes

So, there is no need to downgrade? Just run the grub-install again?

i do tested this on 3 installs now and other users on telegram reporting it is working too :wink:

4 Likes

I did update my AMD Ryzen 5 4600U machine and it booted fine.

2 Likes

I decided to install rEFInd, which is great, otherwise I would have had a heart attack when I saw that it took me to the Startup Menu that my UEFI has.

You are right, using the GRUB entry in rEFInd just resets the machine, direct boot works fine though.

It’s nice not having to worry about passing --ignore grub lol

that fixed it for me, too.
I used --bootloader-id=EndeavourOS because that’s what is used by default (at least it showed me that in efibootmgr

3 Likes

MajorTomToGroundControl

5 Likes

good idea :wink:
Adrian de groot implementd something to Calamares that will use random names from a database as bootloader-id to have spaceshuttle names set but we do not get into implementing it jet…

1 Like

So, to replace my current efi entry, I would use UEFI OS ?

$ efibootmgr 
BootCurrent: 0005
Timeout: 1 seconds
BootOrder: 0005,0000,0006,0007,0004,0001,0002,0003
Boot0000* Windows Boot Manager	HD(1,GPT,5cc29a67-eaf6-4fd8-9c41-cdcab9373bd4,0x800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d0000006f000100000010000000040000007fff0400
Boot0001* UEFI:CD/DVD Drive	BBS(129,,0x0)
Boot0002* UEFI:Removable Device	BBS(130,,0x0)
Boot0003* UEFI:Network Device	BBS(131,,0x0)
Boot0004  endeavouros-2297	HD(1,GPT,26ff69d4-01dd-6b42-8435-e2fc79b49e44,0x1000,0x96000)/File(\EFI\ENDEAVOUROS-2297\GRUBX64.EFI)
Boot0005* UEFI OS	HD(1,GPT,26ff69d4-01dd-6b42-8435-e2fc79b49e44,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)0000424f
Boot0006* UEFI: SanDisk	PciRoot(0x0)/Pci(0x1,0x2)/Pci(0x0,0x0)/USB(6,0)/CDROM(1,0x3664c0,0x34298)0000424f
Boot0007* UEFI: SanDisk, Partition 2	PciRoot(0x0)/Pci(0x1,0x2)/Pci(0x0,0x0)/USB(6,0)/HD(2,MBR,0x593e4509,0x3664c0,0x34000)0000424f

This solved my problem too.
So unlucky this happened just before lunch, I use my eOS at work and couldn’t work during the afternoon. No more sudo pacman -Syu at work ever again.

Thank you! If there’s a way to buy you a coffee, I’d like to do it.

:enos:

only one little thing very small no sudo needed in arch-chroot you will be root anyway … but using it will not harm anything…
Welcome at the fun b.t.w. and thanks for just diving into help a lot of users with a detailed tutorial!

1 Like

One should keep an eye on any update of the grub-package during system-upgrade at all times. They’ve proven to be tricky to various system configs (especially multi-booters) in the past.

Next scary thing coming up: Update to cups!

1 Like

Ok I chrooted in did sudo downgrade grub Selected previous version let it do its thing, then it asked me to add grub to Ignore Pkg? [y/N] I hit y then reboot and it still boots directly to my bios. Did I miss something?

These instructions are very complex and though I will try them, I don’t have too much hope in the outcome.

I do have two questions which just came to mind.

  1. Is it possible to reinstall EndeavourOS while keeping the previous /home directory?

To give an example, when I used MxLinux many years ago, it was possible to do just that (keeping the /home directory when installing a new version). If this were possible with EOS, that would “solve” the problem for me, at least in the short run AND it would be much easier for me.

and

  1. Will there be a prominent notice here on the forum when GRUB has been fixed and it is safe to update normally?

I have been using EndeavourOS on many computers for the three years it has been in existence and this is the first time there has been a major problem.

I certainly hope that it can be fixed quickly.

Lawrence

Keep an open mind, just go through these steps one step at a time.
You will be able to fix your system very quickly. These instructions aren’t hard. It looks challenging before you try it but just go through them slowly and you will be okay.