Google Earth rendering issue

Hey everyone! When I’m using Google Earth and zoom in, this is what happens:

My GPU Drivers are updated and this issue happened in openSUSE too.

[xico-endeavour@xico-desktop ~]$ inxi -G
Graphics:
  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT / 6800M] driver: amdgpu
    v: kernel
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
  Display: x11 server: X.Org 1.21.1.3 driver: loaded: amdgpu,ati
    unloaded: modesetting,radeon resolution: 1920x1080
  OpenGL: renderer: AMD Radeon RX 6700 XT (NAVY_FLOUNDER DRM 3.44.0
    5.16.1-zen1-1-zen LLVM 13.0.0)
    v: 4.6 Mesa 21.3.4
[xico-endeavour@xico-desktop ~]$

This happens in Firefox too, but I use Vivaldi.

Does anyone else have this issue? Thanks :slight_smile:

I have something strange displayed at all…

1 Like

I’m facing the same problem, but depends on the camera (zoom).

1 Like

Same, it only happens at a “medium zoom”. If it’s too close or too far, it doesn’t happen.

1 Like

Works fine for me on Firefox, i’m on Nvidia so maybe it’s drivers issue?

P.S. KDE / X11

1 Like

It could be, its definitely not wayland or X11…
@xinux26 is on X11 and I’m on wayland and the same problem happens, we both using AMD video card…

$ inxi -G
Graphics:
  Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] driver: amdgpu
    v: kernel
  Display: wayland server: X.Org 1.21.1.4 driver: loaded: amdgpu
    note: n/a (using device driver) - try sudo/root resolution: 1920x1080~144Hz
  OpenGL: renderer: AMD Radeon RX 6600 XT (DIMGREY_CAVEFISH DRM 3.44.0
    5.16.2-zen1-1-zen LLVM 13.0.0)
    v: 4.6 Mesa 21.3.4

Edit: Tested on firefox here

1 Like

That’s weird… Maybe it’s a driver issue then? What should I do to report it?

Maybe… Not sure really…

1 Like

Just upgraded a few packages and now the problem is gone.
Not sure if the upgrade solved the problem or if it was Google Earth that fixed something…

[2022-01-28T09:26:49-0300] [ALPM] upgraded lib32-mesa-vdpau (21.3.4-1 -> 21.3.5-1)
[2022-01-28T09:26:49-0300] [ALPM] upgraded lib32-vulkan-radeon (21.3.4-1 -> 21.3.5-1)
[2022-01-28T09:26:49-0300] [ALPM] upgraded libva-mesa-driver (21.3.4-1 -> 21.3.5-1)
[2022-01-28T09:26:49-0300] [ALPM] upgraded mesa (21.3.4-1 -> 21.3.5-1)
[2022-01-28T09:26:49-0300] [ALPM] upgraded mesa-vdpau (21.3.4-1 -> 21.3.5-1)
[2022-01-28T09:26:49-0300] [ALPM] upgraded vulkan-radeon (21.3.4-1 -> 21.3.5-1)

Edit: Ops, it happened again. :frowning:

1 Like