Google Chrome

How to get ride of password while opening google chrome. It prompts for root password.

How did you install Google Chrome?

Yay -S google-chrome

Ok. Installed it, and I have no “please enter your password” dialog box. Weird :frowning:

I have the issue

Not sure from your description, but this post may be relevant.
https://support.google.com/chrome/thread/3452787?hl=en

1 Like

It is beyond my knowledge and control.

sure it asks for root password? as it could be it ask to unlock session key for user, if you are using autologin to Desktop Environment and the key do not get unlocked

Yes Sir. Xface desktop. Not every time only when launching google chrome after rebooting pc.
The message displays as below;
" The login Keyring did not got unlocked when you logged into your desktop."

OK - one solution laid out a in a manner more easily understood…
The icons that each program ‘owns’, and is displayed on such things as docks, are directed by a file called application_name.desktop. What we are going to do here is move a copy of that file to your local directory, where its setting will have priority over the system settings when you are logged ion. First we make sure that the directory ‘applications’ exists in ~/.local/share. Create it if it’s not there. Then

cp /usr/share/applications/chromium-browser.desktop ~/.local/share/applications

Check that it made it there. Now it needs some editing. You could use the sed command given in that post, or just open the file with a text editor, and add the line in yourself. Depending on your DE, you may be able to do it by editing the Properties tab in your file browser instead. (edit: I see you’re on XFCE, so that is a good choice to use) Any which way, add this:

--password-store=basic

either in the box for command in Properties/Lancher, or between the Exec=chrome-browser and the %U, with spaces surrounding it.
I am not sure of the exact contents of your Exec= line, as I don’t run Chrome, but it should be clear where to put it if you’re hand-editing.

Once this is done, the next time you start it up, there should be no demand for a password - but also no extra protection for the passwords stored in your browser. Which may not matter, if your main user password is good, of course!

Hope this helps, and clarifies what is suggested in the past.

that’s what i say the login-keyring of your user not root.

I didnt understand what you are saying?

I can make use of google -chrome by providing root password of OS which was created while installing. No issue subsequent running of google-chrome.

per default install will use the same password for your user created on install and the root-user. but they are still two different users.

google-chrome asking for is the login-keyring of your normal user, it is usually unlocked on login. (if you use loginmanager and not login to your Desktop without login-manager)

I am logging desktop with root password only. Still asking while launching google chrome

that is normal on google-chrome if gnome-keyring is installed you need to follow this:


to get rid of the password asking.

But again you do not login with your root-account to Desktop, it is your normal user-account.
root-account and normal-user-account only have the same password. a user have a username and a password.
if you put
username = nnriyer
paswword = 234
you will login as this user also if the password is the same as for:
username = root
password = 234
it is always the combination of name and password.

if you use gnome-keyring and chromium based i thought if you enter the first password blank , it doest go back asking password :slight_smile: if you enter a password it going back.

Also check that your user is in the wheel group and enable sudoers for the group. Gnome doesn’t like the special sudoers file that EOS uses

It should use polkit afaik, which doesn’t have anything to do with sudo…