GNOME will not change to dark theme

Hello all.

I just installed EOS with GNOME, so this is a clean install. When switching between light and dark theme from settings, there is no change.

I went into special settings and set older programs to Adwita-dark, and this is what I get

I am still researching this topic, but one of the solution is to try to force dark theme:

gsettings set org.gnome.desktop.interface color-scheme 'prefer-dark'

which didn’t do anything.

I am not big on light theme, and prefer dark, so if someone has an idea of what to do or where to look, please let me know. I am totally fine with default GNOME dark theme :slight_smile:

OK, little progress, it seems that user theme for GNOME shell is not installed or not running.

I have not been able to find user theme for GNOME shell in AUR, and I have not been able to install it directly from browser. I have never been able to enable extension by downloading it from GNOME extensions.

Take a look at itsfoss.

I don’t use gnome but i found this on the fly. May it help you with your installation

It seems to be identical to this problem:

then install this:

sudo pacman -S xdg-desktop-portal-gnome xdg-desktop-portal

That’s it!!! :partying_face: Thanky very much :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.