GNOME Files cannot connect to Samba servers by default

Installing EndeavourOS with the GNOME flavor installs avahi and nss-mdns by default, but doesn’t enable hostname resolution for mdns, causing this issue when connecting to a samba server

image

I think the installer should enable this by default

EndeavourOS provides a basic Arch system - you do the rest.

Including but not limited to adding extra packages for setting up your prefererred experience whether this is an office application suite, a printer or shared folders.

EndeavourOS is an expressway to install Arch with some added tools we developed ourselves and even not all of those tools aren’t installed by default.
We want to provide you to explore Arch with that same friendly community-feel Antergos was known for and whether you use FOSS apps, closed-source apps, a combination of those and solely use the terminal or use GUI tools in that exploration, it is up to you, it is all about the journey with us! - Does EndeavourOS allow GUI package installers?

1 Like

shouldn’t the installer also add a basic configuration to the packages that installs?

You have to understand that our DE installs are the most basic installation versions Arch offers. It is up to you how you configure the system.
Not everybody has the need for connecting to a network server, just like that, not everybody has an HP printer, for instance.

It is that basic setting which gives you the power to tinker your system to your needs.

3 Likes

hm same would count for Printer setup where you need to enable local hostname resolution in some cases.

This is simply not enabled per default upstream.
We do not enable samba per default, same for Bluetooth and a lot of other stuff.

But indeed samba could get some better documentation to solve this issue easier.

We have the hint to enable localhostname resolution already in printer wiki:

Is it the same as what is needed for samba-shares?

1 Like

if you can provide the steps to enable this I would love to add a tutorial for it to the wiki.
And I can go testing it also.

2 Likes

Is it the same as what is needed for samba-shares?

Yes, at least on GNOME

if you can provide the steps to enable this I would love to add a tutorial for it
Should be the same as the one in the arch wiki

  • Install nss-mdns
  • Edit /etc/nsswitch.conf
  • Add mdns_minimal [NOTFOUND=return] before resolve and dns in hosts
    • hosts: mymachines mdns_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] files myhostname dns
  • sudo systemctl restart avahi-daemon to restart the daemon

I think GNOME Files (or gio) expect this to be enabled by default, and it doesn’t give an error message if it isn’t

1 Like

keep in mind that this error occours only if you want to access the samba network directly from GNOME Files in the Other Positions tab, selecting the share in the Networks section.

Connecting directly with CTRL+L works fine

i ditch GNOME a long time ago so not really into the process that would be used with nautilus anymore :wink:

Would be interesting also if it needs some setup on the server side (Windows) to be able to access shares?

I only have shares from Raspberry PIs, so don’t know if there is any setting up required for Windows shares

ah good to know, i can go checking this… i have some windows systems in local network to check that.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.