Gnome does not start on newly installation

Hello,
coming from Ubuntu and Antergos I have already successfully installed one laptop with EndeavourOS. Everything is running fine, including Gnome. Installation was done with the version from august.

Now I wanted to install the next PC with the latest october version. Installation went fine, but when I wanted to change from XFCE to Gnome, I was not able to start Gnome. Everytime I tried to do it I got the message “oh no something has gone wrong. a problem has occurred and the system can’t recover. Please Log out and try again.” and I had to go back to XFCE.

Checking all the logs (journal, lightdm, x etc.) did not give me any hint, where problem comes from. I then tried again the installation version from august. Using this as the basis for the installation makes Gnome work.
Does someone know what is the difference between the two installation versions? I would like to use the october version (or an later version), because the installer is much more comfortable.

Kind regards
Martin

Hi welcome on the forum. Did you update the system before installing Gnome?

can you give some hardware information. and you use gnome with lightdm i see ?

Yes, after installing the system I made an update (yay -Syu or pacman -Syu) and then installed Gnome.

The hardware are two older Fujitsu devices with Intel processors without integrated graphics and one i5-4xxx with integrated graphics. All systems have 4GB or more memory and harddrives with enough space. I tried the installation with the october version on three different devices more then five times. Most of the installations were very similar. Later I tried to install with manually partitioning the drive or automated by the installer, with or without encryption. Every time with the same problem.

Yes, Gnome on lightdm.

Try to install GDM.

I did. Then Gnome worked but XFCE did not work any more. I had to switch back to lightdm.
I would like to use lightdm with both Gnome and XFCE.

Very irritating for me is, that using the august version to install the system makes a system, where XFCE and Gnome both work with lightdm. With the october version only XFCE works with lightdm.

The difference is the kernel version, but if you install from the august iso and update, you’ll get the same problem.
Sorry, I’m in the middle of cooking, I’ll come back to you

No. If I install from august und then update to the latest kernel version, Gnome is still running fine.

Happy cooking! :slight_smile:

I just checked the different installations. All are running with kernel 5.3.8.1-1. The ones with the installation from august get Gnome running, the one with the installation from october don’t.

its stil a roling release if you dont change to the linux-lts package at the end versions goes to the same.

as it sounds weird gdm works with gnome then not xfce and vice versa , lightdm only for xfce…

what you can try to do is , pacman -Qq > pc1.txt and take second pc , pacman -Qq pc2.txt , then try to compare with meld but october version technically does not have a huge difference mayby minor.

I made that diff. Only some packages where different. I installed the missing ones on the october installation, but Gnome is still not working.
I will do some further testing.

As you said: very weird.

installed gdm in virtualbox i noticed gnome-session and gnome-desktop are depency, so you have a mini gnome install on this point…Xfce seems to work , check your xorg configurations probably there is some answers?

Thanks for that idea!
I will look into that during the next week or maybe the next weekend.

For now I have found following workaround:
I started the installation with the august version. After the reboot I updated the local databases and then installed the new welcome. I used the update mirror to get the fastest local mirrors. At the end I made a complete system update and installed gnome and gnome-extras. Now I have a completely updated system and Gnome is working fine.

Does the installed XFCE work properly?

Started from lightdm, yes.
Starting from GDM does not work with XFCE.

Personally, after installing a new desktop offline, I don’t usually install another display manager, but I use the same one I used to do.

dont know why there should be a reasion ?

chech .xsessions-errors ( or .xsession-errors)

do su in terminal and go to /var/log/gdm

look if you find some logs…
trying to recreate by as example saving the xfce session… no clue, xfce saved sessions are in ~/.cache/sessions if you do ls you might find xfce4-session , remove that
mayby is cause a session file it saved? i dont know gdm should work

looked intoo this topic : https://www.linuxquestions.org/questions/linux-desktop-74/xfce-will-not-start-from-gdm-in-debian-sid-808051/

you might check te hidden .ICEauthority (in filemanager ctrl+h)

mine is blank atleast

1 Like

I made a lot of new tests to find the cause of my problem. Once again I installed both versions and tried to find differences between both, that may be the cause of the problem. I also compared the X configuration, but I was not able to find something, that is a problem.

So by now there is only the workaround from me mentioned in https://forum.endeavouros.com/t/gnome-does-not-start-on-newly-installation/2196/14

I will wait for the november version to repeat the test.