GNOME display flickering at high refresh rates with specific applications


First off, I apologize for not including much terminal information, I am not sure on how to do that, please let me know how to do that so I can make diagnosis of the problem easier.

The main problem that I’m having is that I get these flashing green diagonal lines on the primary display when using youtube for video playback and engaging the tiling hint over the video. I use a dual display setup at 144hz each.

Here is the setup:

  • Primary display is right, secondary is left.
  • Primary display has Firefox maximized. YouTube video is in “Theatre” mode.
  • I start Nautilus, and I drag it so that the tiling hint is over the left side of the primary display.
  • Once I move the mouse further than the limit that is needed to engage the tiling hint (the tiling hint is no longer present), the tiling hint fades, but for a brief moment the display will flicker with diagonal green lines. It is reproducible.

I have checked cables, displays, and I have even bought a new graphics card as well. Sometimes the graphical bugs with the horizontal lines will happen during the video playback, causing a constant flickering. I have even tried different PCIe slots in my board to see if the issue is the board.

I’m somewhat at a loss for what to do since no one else seems to be having this problem. Thank you very much for your time.

I also have images available to show the graphical glitch. Additionally I can set the video to a specific frame and the graphical bug stay on the display.

I originally posted this to the GNOME discourse, but I haven’t gotten a reply and I’m not quite sure how to diagnose the issue. I’ve used journalctl to see if there’s anything in there, and there are a few window manager warnings, but I’m not sure where to go from there.

Hardware infos would be good. Could be nvidia graphics card/driver related.

Thanks for getting to me, I apologize it took so long to reply until now. I have tried many different things in order to see what the issue could be, but none have succeeded.

I have replaced cables, replaced memory, replaced the graphics card with a different card, tested all PCIe slots on my motherboard, tried using KDE but still got the same bug.

I’m about to the point where I’m ready to go ahead and get a new CPU and motherboard in all honesty.

A big point of interest is that I’m able to “nullify” the bug if I decrease my brightness on my monitor.

Anyway, here are the logs, I’m really at a loss right now.

inxi -Fxxc0z | eos-sendlog:


Kernel: 6.1.3-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
Desktop: GNOME v: 43.2 tk: GTK v: 3.24.36 wm: gnome-shell dm: GDM
Distro: EndeavourOS base: Arch Linux
Type: Desktop System: Gigabyte product: Z390 AORUS MASTER v: N/A
Mobo: Gigabyte model: Z390 AORUS MASTER-CF v: x.x
serial: UEFI: American Megatrends v: F10
date: 10/15/2019
Info: 8-core model: Intel Core i9-9900K bits: 64 type: MT MCP
arch: Coffee Lake rev: D cache: L1: 512 KiB L2: 2 MiB L3: 16 MiB
Speed (MHz): avg: 4275 high: 5001 min/max: 800/5000 cores: 1: 5000 2: 3600
3: 3600 4: 4984 5: 4889 6: 4995 7: 5001 8: 3600 9: 4912 10: 3600 11: 4850
12: 3600 13: 3600 14: 4973 15: 3600 16: 3600 bogomips: 115232
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] vendor: Gigabyte
driver: i915 v: kernel arch: Gen-9.5 ports: active: none empty: HDMI-A-1
bus-ID: 00:02.0 chip-ID: 8086:3e98
Device-2: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT]
vendor: Tul / PowerColor driver: amdgpu v: kernel arch: RDNA-2 pcie:
speed: 16 GT/s lanes: 16 ports: active: DP-1,DP-2 empty: DP-3,HDMI-A-2
bus-ID: 03:00.0 chip-ID: 1002:73bf
Display: wayland server: v: with: Xwayland v: 22.1.7
compositor: gnome-shell driver: gpu: amdgpu display-ID: 0
Monitor-1: DP-1 model: MSI Optix G24C res: 1920x1080 dpi: 94
diag: 600mm (23.6")
Monitor-2: DP-2 model: MSI MAG241C res: 1920x1080 dpi: 94
diag: 598mm (23.5")
API: OpenGL v: 4.6 Mesa 22.3.2 renderer: AMD Radeon RX 6800 (navi21 LLVM
14.0.6 DRM 3.49 6.1.3-arch1-1) direct render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel
v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a348
Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
pcie: speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
Sound API: ALSA v: k6.1.3-arch1-1 running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:a370
IF: wlan0 state: down mac:
Device-2: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc
IF: eno2 state: up speed: 1000 Mbps duplex: full mac:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 1-14:7 chip-ID: 8087:0aaa
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address:
Local Storage: total: 3.18 TiB used: 79.76 GiB (2.4%)
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 1TB size: 931.51 GiB
speed: 31.6 Gb/s lanes: 4 serial: temp: 36.9 C
ID-2: /dev/nvme1n1 model: PCIe SSD size: 931.51 GiB speed: 31.6 Gb/s
lanes: 4 serial: temp: 39.9 C
ID-3: /dev/sda vendor: PNY model: CS900 500GB SSD size: 465.76 GiB
speed: 6.0 Gb/s serial:
ID-4: /dev/sdb vendor: Toshiba model: HDWD110 size: 931.51 GiB
speed: 6.0 Gb/s serial:
ID-1: / size: 914.85 GiB used: 79.76 GiB (8.7%) fs: ext4 dev: /dev/nvme0n1p2
ID-2: /boot/efi size: 998 MiB used: 312 KiB (0.0%) fs: vfat
dev: /dev/nvme0n1p1
ID-1: swap-1 type: file size: 512 MiB used: 13.5 MiB (2.6%) priority: -2
file: /swapfile
System Temperatures: cpu: 34.0 C pch: 48.0 C mobo: N/A gpu: amdgpu
temp: 56.0 C mem: 58.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Processes: 372 Uptime: 1h 8m Memory: 31.21 GiB used: 5.79 GiB (18.6%)
Init: systemd v: 252 default: graphical Compilers: gcc: 12.2.0 Packages:
pm: pacman pkgs: 1065 Shell: Zsh v: 5.9 running-in: gnome-terminal
inxi: 3.3.24

journalctl -k -b -0 | eos-sendlog: