Display flickers black on mouse movement/scrolling when refresh rate is 144 Hz


I have a fresh Endeavour install on a 1 year old PC. I’m having a weird graphics issue where the screen flickers black when I move my mouse or scroll, but only when the refresh rate is set to 144 Hz.

On my previous Mint install, I encountered this issue only when I disabled GPP0 from waking my computer. This was to fix an issue specific to B550 motherboards that would wake the computer seconds after sleeping.

I previously replied to this thread before @BluishHumility politely reminded me that I should make a new thread.

Things I have already tried:

  • Physically reseating graphics card
  • Physically reseating GPU power cables (on the GPU side, will test on the power supply side soon because it’s a modular PSU.)
  • Checking that the correct drivers are installed according to the EndeavourOS Linux gaming instructions

This computer dual boots windows, and has experienced different graphics issues on Windows where the drivers will hiccup and then Windows will uninstall the AMD graphics drivers, but this is not necessarily related.

System Info:
inxi -Fxxc0z


Kernel: 6.8.1-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
Desktop: KDE Plasma v: 6.0.2 tk: Qt v: N/A wm: kwin_wayland dm: SDDM
Distro: EndeavourOS base: Arch Linux
Type: Desktop Mobo: Gigabyte model: B550I AORUS PRO AX v: x.x
serial: BIOS: American Megatrends LLC. v: F17b
date: 02/08/2023
Info: 8-core model: AMD Ryzen 7 5700X bits: 64 type: MT MCP arch: Zen 3+
rev: 2 cache: L1: 512 KiB L2: 4 MiB L3: 32 MiB
Speed (MHz): avg: 2474 high: 3590 min/max: 2200/4662 boost: enabled cores:
1: 2800 2: 3400 3: 2200 4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 2200
10: 2200 11: 3400 12: 2200 13: 2200 14: 2200 15: 2200 16: 3590
bogomips: 108634
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M/6850M XT]
vendor: XFX driver: amdgpu v: kernel arch: RDNA-2 pcie: speed: 16 GT/s
lanes: 16 ports: active: HDMI-A-1 empty: DP-1, DP-2, DP-3, Writeback-1
bus-ID: 08:00.0 chip-ID: 1002:73df
Device-2: Logitech C920 PRO HD Webcam driver: snd-usb-audio,uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-3:3 chip-ID: 046d:08e5
Display: wayland server: X.org v: with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: amdgpu
unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
gpu: amdgpu display-ID: 0
Monitor-1: HDMI-A-1 res: 1536x864 size: N/A
API: EGL v: 1.5 platforms: device: 0 drv: radeonsi device: 1 drv: swrast
surfaceless: drv: radeonsi wayland: drv: radeonsi x11: drv: radeonsi
inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.3-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
navi22 LLVM 17.0.6 DRM 3.57 6.8.1-arch1-1) device-ID: 1002:73df
display-ID: :1.0
API: Vulkan v: 1.3.279 surfaces: xcb,xlib,wayland device: 0
type: discrete-gpu driver: mesa radv device-ID: 1002:73df
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
speed: 16 GT/s lanes: 16 bus-ID: 08:00.1 chip-ID: 1002:ab28
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
bus-ID: 0a:00.4 chip-ID: 1022:1487
Device-3: SteelSeries ApS Arctis 5
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 bus-ID: 1-1:2 chip-ID: 1038:12aa
Device-4: Logitech C920 PRO HD Webcam driver: snd-usb-audio,uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-3:3 chip-ID: 046d:08e5
API: ALSA v: k6.8.1-arch1-1 status: kernel-api
Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin
Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
pcie: speed: 5 GT/s lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8125
IF: eno1 state: up speed: 1000 Mbps duplex: full mac:
Device-2: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e v: kernel pcie:
speed: 5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 14c3:0608
IF: wlan0 state: up mac:
Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
speed: 480 Mb/s lanes: 1 bus-ID: 1-8:5 chip-ID: 0e8d:0608
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: disabled
rfk-block: hardware: no software: no address: N/A
Local Storage: total: 1.82 TiB used: 122.73 GiB (6.6%)
ID-1: /dev/nvme0n1 vendor: Silicon Power model: SPCC M.2 PCIe SSD
size: 1.82 TiB speed: 63.2 Gb/s lanes: 4 serial: temp: 37.9 C
ID-1: / size: 489.62 GiB used: 122.73 GiB (25.1%) fs: ext4
dev: /dev/nvme0n1p5
Alert: No swap data was found.
System Temperatures: cpu: 45.8 C mobo: 36.0 C gpu: amdgpu temp: 36.0 C
mem: 34.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
Memory: total: 64 GiB note: est. available: 62.7 GiB used: 5.24 GiB (8.4%)
Processes: 325 Power: uptime: 1h 27m wakeups: 0 Init: systemd v: 255
default: graphical
Packages: pm: pacman pkgs: 1361 Compilers: gcc: 13.2.1 Shell: fish
v: 3.7.0 running-in: konsole inxi: 3.3.33

Additionally, my display is a ViewSonic VX1755. It’s powered with the included USB-C cable plugged into my motherboard, and display signal is provided with the included HDMI to mini-HDMI cable plugged into my RX 6700. That should hopefully eliminate concerns of the cable not supporting the monitor’s refresh rate.

I have been unsuccessful at attempting to diagnose the root cause of this, much less begin looking for a solution. Please let me know if you need any additional information or tests.

The monitor homepage you shared says the at the bottom:

USB 3.2 Type C DisplayPort Alt mode only : 1 (60W power charger)

Maybe it is possible to ditch the HDMI cable and go the DisplayPort variant?

Also is it possible to not use the motherboard for power? Just a normal power outlet?

Otherwise check if disabling adaptive sync (if enabled) does help.

My bet is hdmi is problem.I ve read several plsces that dp is better for higher refresh rates. Ive also had the problem myself. A proper dp cable solved the problem.

Hey I was reading your reply to my topic, and what you have here. The main thing that helped me out was switching out the memory. I had replaced cables (displayport) and even bought a new GPU (went from an NVIDIA 2070 SUPER to an AMD 6800) and it still happened. I finally switched out the memory and it seemed to disappear, but not totally since I still see issues seldomly (mostly fullscreen applications during certain lighting scenarios). I can’t say for sure that this was the issue, but considering you have 64GB of memory you could try and see if a particular stick is causing the issue.

Just to note, I also have a GIGABYTE motherboard and that was the only thing I didn’t change. I also had the same issues in Windows as well so it may be the motherboard manufacturer?

You could also try to update your BIOS, if you didn’t do it already.

Thanks for the suggestions. I’ve tried using a power adapter before, and it hasn’t solved the issue. I’ll switch it to the power adapter anyway to eliminate a source of error when troubleshooting.

As for the DisplayPort, I have been completely unable to get this monitor to actually work with DisplayPort, even though it allegedly supports it. The monitor only supports DP through USB-C alt mode, since it doesn’t have a physical DP or mini-DP port, and does not include an appropriate cable. I’ve tried using DP to USB-C cables, before finding out that most of them are not bidirectional. I purchased a Monoprice cable that advertised itself as bidirectional, but it still didn’t work. At this point I’m thinking I should just replace this monitor, since it’s been a major pain. Even still, the GPU issues have on rare occasion caused the OS to crash and forcibly reboot. Is it possible for a bad monitor/cable to cause that sort of thing?

Disabling adaptive sync did not solve the issue. I updated the BIOS when I built the PC a year ago, but I will try updating to the latest.

I’ve acquired a friend’s spare GTX 1660 Ti to test whether it’s a hardware issue. I’ll update on whether issues persist after running the system for a few days. If there are any more suggestions in the meantime, I’d love to hear them.

I’m back with some test results. The issues went away when I used the 1660 Ti, however they came back when I used a friend’s RX 6700. This suggests to me that a hardware defect is unlikely.

I updated the BIOS just minutes ago. The issue has not presented since the update, but further time (and GPU load testing) is required to confirm stability. The issue was not present for the first boot after updating the BIOS. I ran Furmark with Vulkan to test stability, then attempted to run Furmark with OpenGL, at which point the screen went black. I switched to another virtual terminal (Ctrl + Alt + F3) and rebooted. On this next boot, the issue returned.

Another test: Switching to an X11 session causes the DE to go black as with the OpenGL Furmark test. This issue persists with both my RX 6700 and my friend’s RX 6700, as with the other issues. I’m at a loss for next troubleshooting steps.

After replacing my monitor, disabling AMD Cool ‘n’ Quiet in BIOS, and enabling Resizable BAR (a.k.a. Smart Access Memory), my flickering issue has gone away. My new monitor is an LG UltraGear 24GN650, connected with DisplayPort. I realize that changing all of these factors at once is unscientific, so I’ll twiddle those options some more and see if I can isolate which one actually fixed it.

Some related information for anyone else on this journey: There’s another common issue with AMD hardware that seems to involve GPU driver crashes causing spontaneous reboots. I’ve had it happen, and also had issues with losing display signal spontaneously after resuming from suspend. It seems like it has a different root cause than the flickering issue. Some have had success fixing this using the AMDGPU feature mask kernel parameters. I’ll open a separate thread about this issue later.