GNOME 45 is Here. What’s Working, What’s Not?

It’s that time again and it seems Gnome 45 is taking two steps forward and 1 step back. So, I was already doing a clean install of Cassini Nova R3, so I was pleasantly surprised that almost all of my important extensions worked (yes @ricklinux Gnome has an extensin for everything).

I dumped ddterm when the devs spent 6 months getting it ready for 44 and that never really materialized. But Tilix and Quake Terminal are an awesome duo.

So I have not got much to complain about so far, but my needs are pretty simple.

What has been your experience and impressions?

1 Like

Very noticeable stuttering when moving the pointer; Settings close unexpectedly without leaving errors when opening the Privacy section. Both with and without any extensions enabled; on Intel graphics, LTS kernel. Coincidentally, NetworkManager started behaving weirdly, which is most definitely related to curl that received an update in a similar timeframe. (Fixed with the most recent libnm-common and networkmanager update)

On the extensions side, there are 2 extensions I use that are yet to be updated: pomoke’s Battery time and qwreey’s QSTweak. The Activities menu update is definitely a fancy, wonderful change, it will replace luchrioh’s Space Bar for me.

Either way, I am back to 44.5 for now and keeping Gnome-related packages (and curl) on hold - I am a bit too bothered by the pointer stutter, and it doesn’t seem like this issue is affecting many people either, so I guess I will wait for an upstream fix. :melting_face:


Sometimes, after I run a Windows game in Lutris, I lose icons in the application menu until I click on where an icon is supposed to be.

Ok, I have Guake installed but didn’t know it ran as a gnome extension…interesting…

1 Like

Ok, I see it’s a different thing. I think I prefer Guake for now and, if ddterm catches up. I’ll reactivate that.

1 Like

This one?

QST just got updated here:

Me too, I have used Battery Time … so :hourglass_flowing_sand:

Thanks for notifying! The update arrived for me a few hours ago. I believe Battery time has also been updated, it’s just awaiting review before it’s live on Gnome Extensions.

The mouse stutter, however, remains and I have no idea what’s causing it. :sweat_smile:


Maybe because Guake and Quake Terminal are not the same. I’m having trouble getting the Quake Terminal to open Tilix with the keyboard shortcut. Maybe I will install Guake after all. I had it before finding ddterm. ddterm needs to support 45.

Yea, that’s what I was trying to say. I think ddterm is better overall than Guake, but Guake does have more theme options.

1 Like

The only extension I used in GNOME 44 was GSConnect. It’s not updated for GNOME 45, which is a bummer. Otherwise, 45 has been running fine for me so far. I like the new workspace indicator on the top left.

im guessing neither Another Window Session Manager nor Smart Auto Move are updated yet. and devilspie/devilspie2 will never work on wayland.

is there another way to get fixed window placement on gnome (as in for example firefox always opening in the position and size i predefine) ?

its something i cant live without, thus im on plasma for the time being, and im not going back to X. Tiling is a horrible solution for me.

1 Like

I found a solution to those broken extensions:
Reformatted and installed KDE Plasma 5.2.7.
OK, so I’m a DEhopper at heart, and so far I’ve left KDE default until I can bend it to suit my workflow. At least I don’t have to rely on extensions like ddterm, Smart Auto Move, GSConnect and I’m sure there will be others.

I still have a Gnome 45 machine next to me with only a few extensions enabled such as Dash to Dock, Espresso. Clipboard Indicator.


Here both GSConnect and Transparent Window Moving extensions are not running.

Gnome seems to have given out the supports 45 tag a bit early IMHO.

That’s nice I guess? I’ve never seen the need for dash-to-dock, Espresso, or DE hopping. The fact that KDE users constantly go out of their way to bash Gnome makes me question why I even bother participating in these communities.

1 Like

I’m finding that some of the “glitchiness” I’ve been experiencing with Gnome 45 went away after I uninstalled GDM-Settings. Found some online forums suggesting it does cause problems with the shell.

My mention of KDE is to give context, not bash a DE, since we are on a Gnome thread and I use both :wink:


GSConnect does work with 45 - you just need to install the latest nightly build as detailed here.

1 Like

My use of extensions is a bit different, I have 13 extensions running with one more I hope comes back someday. I try to run extensions that do ONE thing, i.e. display weather next to clock, disable the STUPID “app is ready” notification, change the Activities indicator to i3 like numbers, kill the start-up in overview, etc. That way when Gnome does its frequent Macintosh fetish of 100% non-backward compatibility I’m only out one function and there’s usually several replacements. (In this case 6 extensions were made obsolete, but I found better replacements.)