GLibC error after update - can't boot

Hey all! :slight_smile:

After updating yesterday and cleaning up my laptop from DEs I wasn’t using and cleaning pacman cache after this, I can’t boot into the system anymore.

When turning on I see the EOS splash screen, and whether I choose normal boot or fallback boot entry I end up here.

I don’t know how to proceed to fix especially as it seems the laptop doesn’t read any of my keyboard usage as you can see here: https://streamja.com/pMMG6

Secure boot is disabled.

If I try to get into grub by pressing ESC after pressing F12 while booting to get into boot image selection it crashes immediately and goes straight to the EOS splash screen, and then to the error above.

Looks like you did a partial upgrade, so you can recover using a chroot,

Once you can access the installation you can fully update it.

6 Likes

I would see it exactly like @jonathon … partly updated system.
No way (no easy way) to boot directly into system. So arch-chroot is your way to get packages at the same level updated…


local/glibc 2.35-2
    GNU C Library

Is the current version… and it searches for 3.34 on your system so would be Glibc is updated but some other parts not fitting it…

3 Likes

I chroot into the system from a base Arch USB. Ran sudo pacman -Syyu, had a few updates, then exited chroot. Shutdown, booted and same error. Maybe I need to downgrade GLibC or something like that?

System is fully updated. Not sure which parts are not fitting in, should I try to downgrade this GLibC package?

That won’t help, it will just make the system even more partially updated.

The error messages you posted disagree.

Have you held back any packages in /etc/pacman.conf's IgnorePkg ?

Have you refreshed your mirror list to make sure you’re using an up-to-date mirror?

1 Like

do you rebuilded kernel images? mkinitcpio -P in the chroot?

No package in the ignore list.

I updated mirrors and updated system, now I don’t get that error anymore but just a blank black screen and a blinking cursor in the top left corner of the screen with no information whatsoever.

I didn’t before, did this time and this was the output

Now I don’t get the GLibC error, but just a blank black screen with a blinking cursor and no other information.

The update seem to have worked. The firmware error messages are also on my computer and should not be the problem I think.

What did you mean by cleaning up your DE in your OP?

1 Like

You can see the boot messages by editing the GRUB boot line (press ‘e’ at the boot prompt) and removing the word quiet, then pressing F10 to boot.

Also, this:

Did you remove Xorg or your DM or something?

I had gnome, xfce and i3 installed but have only been using i3 for the past few months so I followed the guide on the EOS website to remove the xfce and gnome desktop. I also used the package lists posted on GitHub to make sure I have all base group packages and all i3 packages.

I’ve seen in a few threads here in the forum that lightdm has been acting up recently so it might be that.

I had a recent install with Cinnamon using lightdm as display manager. It refused to start. Replacing it with ssdm worked for me.

Also, if this is the issue in your case, you could look into starting i3wm from TTY with xinit:

https://wiki.archlinux.org/title/I3wm

I removed “quiet” and don’t see any error in the grub booting. I followed the guide linked and this was the output

^ running the Dkms

then i ran startx and I see this

I did probably remove the gnome DM but my i3 was already set to work with light DM iirc

Check if you have xorg-xinit installed. If not install it.
Put exec i3 in ~/.xinitrc.
Log in from TTY and startx.

Hope this helps!

It was already installed. I copied the config from /etc/X11/xinit/xinitrc to ~/.xinitrc then edited and saved as advised.

When running startx I see the same exact screen as above with 3 windows opened in a weird placement

I do have Light DM installed

and here all packages with starting with x installed

Remove the lines 50-54 and try again.

2 Likes

It works! Only bummer I have to login every time into tty and do startx

Will scout arch wiki on how to fix, any advice?

1 Like

This looks like what happens when the installer installs the base but not all the configs get pulled in from github. Something went very wrong with this installation.

1 Like

is lightdm enabled ?