Getting Xorg to work on a 210 DPI display


  • I have a 2560x1440 14" laptop screen.
  • Everything on Xorg appears to small by default because the default dpi is 96

Attempted Workaround

  • 192 would presumably be ideal for me
  • I followed the instructions on here to make that my dpi & applied the other settings listed in the example Xresources file


  • I tested this on AwesomeWM
  • The GUI of AwesomeWM scaled correctly with the new dpi
  • The GUI of Qutebrowser scaled correctly with the new DPI
  • Webpages appeared to have a dpi of 96
    • I will test on Firefox when I get home
  • The terminal I used (Kitty) went past the bottom of the screen for some reason

Is there something more or something different I might need to set?

I’d start here: and then follow on to Setting the output DPI will have it apply to all applications running under the Xorg session.


Unfortunately it’s not that easy, there’s also gtk / qt scaling

You can see some of that here on the bottom

Thanks, I’ll try this & report back.

I have a 2560x1440 screen but it’s 24". I set the dpi to 117 in .Xresources. I don’t use XFCE, but I seem to remember that selecting a scale factor of 2 makes the text far too large.

That is not the only choice anymore - in the Settings/Display mini-app, you can choose whatever number makes you happy (or allows you to see). The only gotcha is that the values go the reverse of expected(!) in Display - so try the Custom, and perhaps 0.7 as the value as a ‘test shot’ starting point.

I am running 4K on a 28, and found that wasn’t too bad, although I mostly just kick the DPI up to 120 and increase font sizes (see the EnOS wiki entry for details).