Getting Hyprland

It surely looks interesting. I’m not sure it’ll end up a community edition, but I can say a solid how to write up from a bare EOS install would be really cool.

It’s a pretty niche wm, amongst many wm.

In case it might help, I started blogging about configuring Hyprland from scratch in EndeavourOS :slight_smile:

12 Likes

And here’s part II

9 Likes

Imho, the community Sway edition here is really good. For those wanting to make the switch to using a WM in Wayland over X11, it makes a great point of entry.

I installed the Sway desktop initially, from there I just used my dot files that I set up for Hyprland from when I was running plain old arch. Works great.

Judging by it’s popularity on r/unixporn, and as it becomes more stable and accessible , hopefully, one day it will become available as a community offering.

There is EOS Hyprland, https://github.com/EndeavourOS-Community-Editions/hyprland
but seems no one working on it anymore… that is sad, because that WM is really good

Looks like archinstall provides Hyprland as a WM choice

Did you tried it ? it is just hyprland base or some configs also ?

The archinstall DE/WM options should all be the basic stock config and no customization.

1 Like

@Brtza Yes, I was aware of the EOS Hyprland, and I agree it’s a fantastic WM. Perhaps when Wayland gains more traction and acceptance, someone will see the value in continuing the project.

@lorebett Normally, the archinstall works just fine for me. With 2023.08.01, I had a couple of weird issues.

One being the install fails because of pipewire-jack and jack2 being in conflict.

I also tried installing it with no additional added packages and the no audio option, using MATE as a test base. It installed, but network-manager was missing. I had enabled it in the archinstall though.

I’ll revisit the 2023.09.01 archinstall when it comes out, and test out the hyprland option then. Hopefully, they fixed the typo “hyperland” in the options menu lol.

I have tried it and it is hyperland base with a very some basic configs. No waybar or wofi or anything.

1 Like

I have Hyprland set up on the latest EOS Sway Community Edition, Ags and dependencies. To get basic functionality, I uninstalled mako (graphical notification daemon) and xdg-desktop-portal-wlr. However, the AGS bindings don’t get picked up, probably down to this error (AGS is a GTK3-based but written in JS/TS) . Also the launcher still looks suspiciously like mako (Hyprland uses wofi) and if I launch Firefox from TTY3 it winds up opening in the Sway session on TTY1 :stuck_out_tongue:

A few weeks ago I set up Hyprland on EOS with the NWG-Shell a GTK3-based user interface for Sway, which now offers an option in the script to install Hyprland. It worked okay out of the box, but it wasn’t picking up my keybindings as far as I recall and I went off to investigate installing on NixOS with a Flake, thinking that would be easier. It was not, hence I’m back! I’ve been a Debian user for 20 years; new to Arch and to Window Managers. Sway has been pretty nice so far while I set up my dotfiles and/for Hyprland. I’m enjoying the terminal-centric approach.

Gotta feel for the bloke who’s “Hyperland” config was rejected by archinstall. The Neovim/telescope aesthetic in the last couple of years has driven the demand for a similar WM workflow for the desktop, lunarvim and lazyvim for ide and editor, ranger as default file manager, lsparu as the package manager, even down to mapping space2meta. This is the Community Edition I’d like to see.

1 Like

Welcome to EndeavourOS @briainod Nice to see another Hyprland user here.

Thank-you @meurglys. Aspiring hyprland user. Finding sway pretty comfy already to begin with, but already know, there’s no turning back :wink:

For the longest time, I used the herbstluftwm, bspwm, and spectrwm window managers under X11. But, I wanted to try something newer, and actively being developed.

I recently made the switch to Wayland, and Hyprland was the first WM I tried. I would agree, no turning back lol

@lorebett Nice blog. Thank you for sharing. Though I’d still like to point out a typo you made in the blog. There’s a line in there where you accidentally typed pacman -Sy which may lead to a partial upgrade.

Thanks! Maybe it was enough to first update the system and then use -S only

So, from what I understand, archinstall for Hyprland is broken.

@lorebett Usually, I test out the new archintall at the first of every month on an old laptop I have kicking around. 2023.08.01 is the first time I have experienced great difficulty in getting a bootable/usable system up and running, or to just plain install. Which is very surprising, considering that for months on end I’ve had zero issues with the installer.

So, I don’t know if it’s a Hyprland thing per se, but I was tracking the archinstall issues git and seen people have opened a few of the issues I am having with the current installer

On the bright side, happy to report Hyprland works great here in EnOS :smile:

To think that supporting Hyprland during the installation was one of the novelties of this version of archinstall :wink: