Getting a "could not create new connection" error when importing VPN configuration

I’m just doing a test install of protonvpn to get my bearings straight with how openvpn works. I created a zip file from my proton account for the vpn configuration. when i try to import a new vpn config i get an error that says

Could not create new connection
The VPN plugin failed to import the vpn connection correctly: configuration error: unterminated double quote at position 218 (line 12)

I assumed this meant that one server config was in there twice but i dont see anything. Ideas?


A double quote (" ") needs to have both the opening quotes and the closing quotes. This error message is saying the config file has a line where the closing quotes are missing.

Check on line 12, see if you can identify the issue. If you are stumped, paste the config into the thread and maybe someone else can spot the problem.

I can’t access the config file, not sure what i’m doing wrong but i’m following wiki.

[root@comp ~]# openvpn /etc/openvpn/server/server.conf
Options error: In [CMD-LINE]:1: Error opening configuration file: /etc/openvpn/server/server.conf
Use --help for more information.
[root@comp ~]# openvpn /etc/openvpn/client/client.conf
Options error: In [CMD-LINE]:1: Error opening configuration file: /etc/openvpn/client/client.conf
Use --help for more information.
[root@comp ~]# /etc/openvpn/client/client.conf
bash: /etc/openvpn/client/client.conf: No such file or directory
[root@comp ~]#

How the heck am I supposed to open this file… this is what wiki said to do, no?

I cant get the config options to appear either… throw me a bone lol

[root@comp openvpn]$ --config file
bash: --config: command not found

Try using an editor, such as nano:

nano /etc/openvpn/server/server.conf

Or you can print directly to your terminal with cat:

cat /etc/openvpn/server/server.conf

To copy from the terminal into the thread, highlight the text and middle-click the mouse, or use Ctrl+Shift+C to copy from the terminal.

1 Like

That was pretty neat, the wheel click, thank you.

Yea, i just accidentally wrote out all my chicken scratch onto the file, thinking write out meant it’d print the contents of the file. FML

The cat command didn’t seem to locate the file either:

[root@comp ~]# cat /etc/openvpn/server/server.conf
cat: /etc/openvpn/server/server.conf: No such file or directory

Oh I’m not sure where we got that path from. Where is the config with the problem then? :crazy_face:

Check what’s in that directory:

ls -R /etc/openvpn

No, i mean i wrote a bunch of chicken scratch commands on nano then executed the command write out, thinking that was how to print the contents from the file. it ended up writing all my failed commands into the file and now those are the contents of server.conf =[
I will need to “write out” the original text from this file, or somehow replace it with a default version of the file now arghh lol

when i try your last command, it says:

[root@comp]# /etc/openvpn/server/server.conf
bash: /etc/openvpn/server/server.conf: Permission denied

That doesn’t look like any command. It looks like you are logged in as root as well, is that right?

This command will show the contents of the /etc/openvpn directory:

ls -R /etc/openvpn

Hmm, it sounds like it might be easiest to just start over, and import it again. Just to check:

Is that how it comes, in .zip format? Make sure to unzip it before you try to import it.

This will be worth a read through if you are stumped:

Thanks for the schooling, I’ll note that command down.

The zip format is the protonvpn file i downloaded, that i was using to try to import as a new VPN network setting.

You told me the server.conf file that is a default system file in openvpn had a double " ".

I accidentally wrote over the entire file using the “write over” command in nano, so now i need either all the stock text from a normal server.conf file, or i need to replace the entire file. But i have no idea where I’d find that. This OS is kicking my butt.