Games lose FPS on long sessions

As the title says. I’m having an issue where the games I play lose FPS the longer the program is running.

The two examples I have are Detroit become human where the game will adaptively keep lowering my shaders and FPS over the course of a long play session usually becoming unbearable about 5 hours in.

And War Thunder starting at 100FPS roughly on a fresh launch and slowly dropping down to 30FPS after about 3-4 hours I’d estimate.

I’ve tested both of these in my windows environment and have no issues with them.

I’m running an X570 chipset with an AMD R7 3600X with a Radeon 6800XT GPU so my specs are not low.

I don’t believe it’s hardware related. It’s certainly not thermal throttling or a memory bleed. The temperature for both my CPU and GPU stay rather static.

I’m at a loss as to what could cause this problem so I’m here to see if anyone experienced something similar in the passed.

I’m also a major Linux newbie having only used Manjaro, POP and EOS for about 6 months. I’m unfamiliar with formalities and requirements for spec and log posting so please accept my pre-emptive apologies.


Welcome aboard! :rocket:

Hmm…Well it’s weird, certainly that would be most logical conclusion when it comes to time = degraded performance…

Other possibility might be RAM errors due to voltage instability or overheat (i’ve seen that on some DDR3 systems rarely), What’s your RAM brand / model?
Have you tested it with Memtest?

Is it Sream or Wine?
If Wine - have you tried different Wine version or TKG / GE?

Which desktop environment are you on?
I suggest monitoring RAM usage in task manager or htop to check for memory leaks.

1 Like

As for my RAM I’m using 3600MHZ DDR4 patriot viper. I have XMP enabled for 3600MHZ. I haven’t tried a memtest.

I’m using steam for War Thunder as the proton version doesn’t work and Proton 6.14 GE for Detroit. I’m not sure what TKG is.

I’m using XFCE4 with desktop compositing turned off. My memory doesn’t seem to be capping out at any point but it is a large 32GB dual channel kit. I can monitor it a bit more closely to see if it’s changing over time.

Wine engine

1 Like

I can’t quite wrap my head around the memtest86+ or how to use it.

I tested out another set of RAM that I have lying around. HyperX fury 3200mhz 32GB and I get the same problem.

I’ll take another look at memtest to see if I can make heads or tails of it in a bit.

If it was a memory leak, wouldn’t it be just one program? And wouldn’t just restarting it restore it to initial performance levels? If it was your RAM I would think more than just a games would be having issues.

Now if you have bad system memory, memtest86 is easy enough to use to check. Just load the iso on a bootable USB. Make it with Ventoy or whatever. Then boot into memtest86 use default settings 1 run should be enough to find out if your memory is bad. Run it 4 cycles if you really want to be sure. I had issues with my XMP profiles. Even though my memory sticks said they were capable they weren’t and I had to manually adjust or use base settings to stop memtest86 from throwing errors.

Don’t know how to check gpu ram…

To me it sounds more like thermal throttling. How are you monitoring temps? what temps are they?

Restarting the program does bring it back to it’s original performance settings. Alt tabbing for a while doesn’t bring them back however.

I’m using CoreCtrl to monitor GPU temperature. The only thing I cannot monitor with this program is GPU fans as they’re always registered as 0 despite the fact the program can control them.

I’ll do some extended testing and see where the temps sit around.

Maybe try a new kernel? Give linux-zen a try. Probably some governor issue?

1 Like

You say corectrl shows fans at zero. I haven’t heard too many people having issues with corectrl fan control. Gotta ask, you’re sure the fans are working?

If you want to enable control you might try unlocking the OC controls by adding kernel parameter amdgpu.ppfeaturemask=0xffffffff

And yeah, linux zen is a good kernel

1 Like

Just installed Zen, some improvements. Will test.

I’ll have a look at enabling the OC controls.

The fans are controllable but only with Automatic setting and fixed 100 (fixed from 0-99 does not work)

I’m starting to wonder if the control program is somehow failing to take control from time to time. I’ll have to continue testing. It’s rather annoying it takes several hours of a session to start the issue.

You could try radeon-profile as well