Fsearch: error while loading shared libraries: libicuuc.so.74

When trying to fun fsearch I got this error message:

fsearch: error while loading shared libraries: libicuuc.so.74: cannot open shared object file: No such file or directory

It looks very similar to what is reported here, so I used the solution reported there (namely, create a symlink to the module that I do have):

╰─ ls -ls /usr/lib/libicu* | grep libicuuc.so                                                                                                                                                                                                                                ─╯
    0 lrwxrwxrwx 1 root root       16 may  9 11:25 /usr/lib/libicuuc.so -> libicuuc.so.75.1
    0 lrwxrwxrwx 1 root root       16 may  9 11:25 /usr/lib/libicuuc.so.75 -> libicuuc.so.75.1
 2020 -rwxr-xr-x 1 root root  2062384 may  9 11:25 /usr/lib/libicuuc.so.75.1

sudo ln -s /usr/lib/libicuuc.so /usr/lib/libicuuc.so.74

After that I re-installed fsearch.

However, now when I run it, I get a different error:

fsearch: symbol lookup error: fsearch: undefined symbol: unorm2_getNFDInstance_74

which makes me thing that creating that symlink is not the right thing to do.

Could someone help please?

Cheers, Manuel

You need to get rid of that symlink and do a clean rebuild of fsearch. Run `yay -S fsearch --rebuild then when the option comes up to clean build enter β€˜a’ (all) and for show diffs β€˜n’ (none) and let it run. This will rebuild fsearch using the latest 75.1 version of icu and libicu which were updated on everyones systems a few days ago.


Thanks @wordler !

yay -S fsearch --rebuild did the trick. I had tried without the rebuild flag, I get it now.

Cheers, Manuel

You’re welcome! :smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.