Front USB 3.0 Ports Don't "Autodetect"

I doubt it’s relevant as this issue has never been present in any prior distros that I used this configuration in, but my case is a Corsair 280X and it’s plugging into an ASRock X570m Pro4.

So basically, I plug a usb drive into either of the front two ports and nothing happens. If I reboot the computer then linux see’s the devices just fine as long as I’ve left them plugged in throughout the reboot.
All other USB ports on my computer work fine.

I’m guessing there is a setting somewhere that has turned off polling of those front ports or something?

2 Likes

Welcome aboard :rocket: :enos:

Do you use TLP?
If so - try to disable USB -> USB_AUTOSUSPEND and see if it helps!

You can install tlpui package for easy configuration of TLP :yum:

P.S. If it will help you can also keep USB_AUTOSUSPEND enabled and use USB_BLACKLIST option to enter your usb drive id to exclude it out of autosuspend :wink:

Weird… why is TLP functional on my desktop computer? Lol

Is there any risk in just removing it and purging all it’s config files?

Best available powersaving :upside_down_face:

Since you’re on Desktop and not Laptop - sure, why not :slight_smile: