Fresh installation dont starts after GRUB menu

Hello there,

I did a lot of research and tried many things the last hours but I did not get any solution. Every time I want to start the OS I get the following message:

My itention is to get a dual boot system on my new Acer Aspire 5, so this is what I have done before:

  • I completely deleted the preinstalled Windows by creating a new partition table with the EOS live system
  • I edited the UEFI settings (secure boot off, fast boot off)
  • then I wanted to install EOS first, but I got a similar message to the one above
  • so I installed Windows first, which runs without issues now
  • after that I started a new attempt but now I am here

I formatted the disk few times between the listed steps.

I would be very grateful for possible solutions. (and sorry if there are mistakes, I am not a native english speaker)

Even installing EOS alone gives you the same error?

Yes, I tried this two times before I installed Windows.

Here is a quickie guide to how I would install ‘beside’ Windows…

  1. Install Windows
  2. Fire up EnOS installer
  3. Answer usual questions, choose manual partitioning
  4. create 512 size VFAT partition
  5. (E)dit vfat partition, mount point /boot/efi, flags boot
  6. create main EnOS partition - mount point /
  7. complete the install

That should work, and avoid most problems. If interested in better solutions, read up in our Wiki about (for instance) rEFInd :grin:

1 Like

Hello @derbusfahrer
I just wanted to ask how you created the live usb?

Edit: I’m also curious which model of acer aspire it is? There are a couple of things i would check. I would suggest checking the UEFI Bios and see it it is set to AHCI mode for the drives or not? I would also clear the Secure Boot keys. You probably have to enable it first and then remove the keys and then disable secure boot again.

Thank you for your suggestion. But this is actually what I have done. I tried it once again few minutes ago but the problem is still there.

Hey ricklinux,

I created the live usb like described in the official wiki.

This the Aspire 5 A514-54. I did not find an option that concernd AHCI and I just disabled secure boot without clearing the keys because at this point I wasnt sure if I could break something.

If you are able to boot on the live ISO and post the link to this command. I can look at the hardware to start.

inxi -Faz --no-host | eos-sendlog

You said you currently have Windows installed and you just tried again to install EOS. Are you using the existing efi partition on Windows or manually creating one for the EOS install with other partitions or letting the installer do it?

I looked at the manual but it doesn’t show anything so i can’t even look at the Bios settings.

Edit: Maybe you can check the UUID in fstab and see if it is correct.

cat /etc/fstab

Then check your drive with the following and see if they match.

lsblk -f

Ok forgive me if I have overlooked it but what are you using for install media? Maybe try something else or a different distro just for testing to see if you have a bad image?

When I first tried to install EOS besides Windows I used default options. At the second attempt I partioned it manually.

I also checked fstab and the UUID was allways correct.

And now I am not even able to enter the BIOS menu because only the acer logo shows up. I probably have to reset CMOS first. Never thought this would be so difficult. :sleepy:

Ok this is the hardware log: link

Maybe I try this tomorrow with Debian. But I also rewrited the live usb stick to get sure. And checksums were ok.

Okay I know what the problem is. I just have figure out what you need to do to correct it.

1 Like

So the problem here is you have the following hardware set up.

Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd v: 0.6 port: 4000 bus-ID: 0000:00:0e.0 
           chip-ID: 8086.9a0b rev: class-ID: 0104 

The vmd module has to be loaded so you need to add that to the “modules” section in




Edit2: Here you have to run sudo mkinitcpio -p after adding vmd to the modules section. I just checked and it is necessary.

You also need to add to




Then update grub with

sudo grub-mkconfig -o /boot/grub/grub.cfg

There is one other thing I’m checking on but i think it’s okay for you to try this for now.

If you need any help i can explain how to do it quickly and easily.


If the above doesn’t work then you will have to disable Intel VMD in the Bios somewhere. But, this has been done before on lots of distros so it should work fine.

Edit: I think if you have it installed and make the changes it should boot.

Hey ricklinux,

it works! :grinning: I don´t know how to thank you. I edited the files from live system with arch-chroot and it worked immediately after reboot.

Many thanks for your help! :+1:


Your Welcome. Glad it worked. You obviously know your way around. I hope you enjoy EndeavourOS!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.