Fresh Install, No Ethernet

Hi, Ive just done a fresh install and my desktop is not connecting to Internet. I am getting “IP configuration was unavailable”

inxi -nN
Network:
  Device-1: Realtek RTL8125 2.5GbE driver: r8169
  IF: enp38s0 state: up speed: 2500 Mbps duplex:
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
  IF: wlan0 state: up

It was working fine from USB before the installation was done. I did online installation option.

what can I do to fix this? WiFi works fine. I have W10 Dual boot and Ethernet works fine there.
Mobo: MSI x570 Tomahawk Wifi
using KDE Plasma desktop

1 Like

Welcome to EOS!
What do you get from:

ip addr
1 Like

Please have a look here:

im very new to Linux and not sure how to do this.

I did another fresh Install but Offline this time and Ethernet was working. After the system update and then reboot, its not working again.

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host noprefixroute 
       valid_lft forever preferred_lft forever
2: enp38s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 2c:f0:5d:da:47:d2 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether e0:d4:64:87:d5:70 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.17/24 brd 192.168.0.255 scope global dynamic wlan0
       valid_lft 86315sec preferred_lft 86315sec
    inet6 fe80::f61d:4028:d49c:1fb3/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

try this:

sudo ip address flush dev enp38s0

Because so far, it looks like everything is working on the EOS side, but your router is not giving out the network address.
If that fails, set a manual network address and gateway/dns according to your router’s settings, and try unplugging/replugging the cable.

Maybe installing r8125-dkms from the AUR helps:

yay -S r8125-dkms

Then reboot and see if it works.

Edit: it is a dkms package, so make sure you have the kernel headers installed:

sudo pacman -Syu linux-headers --needed

@ onyxnz

that didnt work.

even after installing this driver, the main driver was showing as r8169 so I blacklisted the r8169 and now it says no drivers even tho we just installed r8125-dkms?

inxi -Nn
Network:
Device-1: Realtek RTL8125 2.5GbE driver: N/A
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
IF: wlan0 state: up

It’s now saying that there’s no driver attached to the ethernet. So try bringing back the 8169, then setting manual IP addressing?

It says connected but i get no internet.

How do make the system use the 8125 drivers?

So if it’s now connected, can you ping to the router address (the gateway)?
If so, check your DNS/Gateway settings, and ping 9.9.9.9.
As far as getting the 8125 onboard, IDK; it should have worked with that, and automatically connected the driver to the card in the boot process of the kernel. Perhaps doing a journalctl -xb | grep 8125 will shed more light upon what is happening there?

I will try that as well but I just loaded the install USB where ethernet works fine and it uses the same drivers

inxi -nN
Network:
  Device-1: Realtek RTL8125 2.5GbE driver: r8169
  IF: enp38s0 state: up speed: 2500 Mbps duplex: full mac: 2c:f0:5d:da:47:d2
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
  IF: wlan0 state: down

so something changed in the last update that broke it :frowning:

journalctl -xb | grep 8125
May 27 11:27:19 Linux-Gaming kernel: pci 0000:26:00.0: [10ec:8125] type 00 class 0x020000 PCIe Endpoint
May 27 11:27:22 Linux-Gaming kernel: r8169 0000:26:00.0 eth0: RTL8125B, 2c:f0:5d:da:47:d2, XID 641, IRQ 102

ping 192.168.0.1

PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
64 bytes from 192.168.0.1: icmp_seq=7 ttl=64 time=344 ms
64 bytes from 192.168.0.1: icmp_seq=29 ttl=64 time=1.27 ms
64 bytes from 192.168.0.1: icmp_seq=50 ttl=64 time=0.829 ms
64 bytes from 192.168.0.1: icmp_seq=63 ttl=64 time=1.26 ms
64 bytes from 192.168.0.1: icmp_seq=87 ttl=64 time=1312 ms
64 bytes from 192.168.0.1: icmp_seq=88 ttl=64 time=299 ms

ping is all over the place

yep, that driver is not great
try sudo bash -c 'echo "r8125" > /etc/modules-load.d/r8125.cfg'
to get the 8125-dkms driver loaded, and blacklist the 8169.
Reference: https://bbs.archlinux.org/viewtopic.php?id=257114

that did not work either, I’m able to blacklist the r8169 but 8125 wont load.

I think im done for now, Im gonna try different distro. i will try this one again in few months. something was changed in last update that broke it so hopefully next update fixes it.
its running fine on my Laptop cause it uses WiFi.

ty for all the help

1 Like

how do I go back to previous kernel?
is it possible to get step by step please.

thank you

Do you have a dual boot with Windows? If so make sure you go into Windows and turn off the fast startup feature under Windows power management options.

Yea I did that already cause it was posted in a different topic also.

Have you tried unplugging the ethernet cable for a few minutes and then plug it back in and let it reconnect.

Have not tried this. I’ll give it a go later.