Freeze again and again - Update Notifier?

Not quite ready to quit EndeavourOS but regular freeze ups making OS too unreliable to use.

Yes, whilst doing mild multitasking the pointer will freeze and the keyboard will not respond resulting in having to hit the power off button.

This has happened many times even during updating which then requires unblocking on fresh boot.`

However when working and it freezes I have noticed that on powering up again; up pops the update notifier leading to me to suspect that the cause of the freeze is the update notifier itself which cannot show, due to some bug whilst working – typing a letter or surfing web, whatever.

I always check for updates every fresh boot; even so perhaps I can disable update notifications before doing any important work or task such as internet banking as I would hate having to crash out in the middle ofsuch a transaction. Hence I have checked the Do Not Disturb slider for the first time this session.

Guess I got used to 100% reliability over the years with Trisquel gnu-linux that this freeze glitch is so annoying – log file link below…

https://clbin.com/paotJ

Thanks – will let you know if the Do Not Disturb slider cures the freeze problem.

You can remove/disable the update notifier if you think that is the issue.

That being said, it doesn’t seem highly likely.

It looks like those logs were taking shortly after rebooting/powering on. Did the issue occur in that timeframe?

Could the following be relevant?

Jan 04 12:11:20 _hostname_ systemd[1]: File System Check on Root Device was skipped because of a failed condition check (ConditionPathIsReadWrite=!/).
Jan 04 12:11:20 _hostname_ systemd[1]: Starting Journal Service...
Jan 04 12:11:20 _hostname_ systemd[1]: Starting Load Kernel Modules...
Jan 04 12:11:20 _hostname_ systemd[1]: Starting Remount Root and Kernel File Systems...
Jan 04 12:11:20 _hostname_ systemd[1]: Repartition Root Disk was skipped because all trigger condition checks failed.

Filesystem corruption? Disk issues? :thinking:

Could be leading to filesystem corruption? Was that a hard reboot?

Trust this is disable notifier - All notifications…?
DoNotDisturb
As I said - will let you know if it cures problem :face_with_raised_eyebrow:

As I understand it users are supposed to use the welcome panel’s log errors and generate a web link. This is what I did after crashing out - powering off - due to freeze up and then firing up again. Hope that clarifies situation…? Feel free to ask again as I’m new here.

After eighth time of same situation I am pretty convinced. Every time after crashing out due to freeze - up pops the notifier within one minute of booting up again.

Setting “Do not disturb” doesn’t stop applications which notify. It just blocks you from seeing the notifications.

That only provides logs since the last boot. So if the issue hasn’t occurred yet when you generate the logs, there won’t be anything to look at.

As I said logs generated AFTER freeze up and crashhing out.

As far as I remember - First task today; unblock updater and update.
After update advised to reboot so rebooted - everything fine.
Did some internet banking, checked emails via webmail, took some screenshots and opened file manager then noticed mouse pointer not moving and no response from keyboard. Waited five minutes before powering off.
Powered back up and as usual noticed update notification.
Updated again and perhaps rebooted again - habit…!
Generated log file web link as advised following instructions from the welcome panel.
Hope that clarifies my actions.

The update-notifier probably checks on boot, then every “n” seconds, so the fact it pops up on reboot is purely co-incidental to your problem.

I bet it uses checkupdates or checkupdates+aur try running one of them from the command line.

Have you tried using the Nvidia drivers. The 4200M is supported by the 390xx drivers available in the AUR.

1 Like

Have you tried to SSH into it after it locks up? You can start SSH with systemctl start sshd or enable it for every boot with systemctl enable sshd. If you don’t have a second computer you can use a terminal/ssh client from your smartphone. Both Apple and Android have them available in their app stores.

I always disable and remove the update notifier that comes with EndeavourOS.

To me, the very concept of an update notifier on Arch seems utterly absurd. Unless you’ve just updated, there are always updates available. It’s like having a notifier that tells you that water is wet.

That said, as much as I dislike update notifiers, I find it very unlikely that this is what is causing your computer to freeze.

In any case, never reboot or shut down your computer by cutting power to it as this can cause filesystem corruption. Instead, enable the magic SysRq key and use that to Reboot Even If System Utterly Broken.

4 Likes

I update daily, so I barely see that update notification; maybe like once or twice a month. I think I had last had it set to checkupdates once every 24 hours. In any case, I think I shall listen to the frog person today and get rid of it. I think it can still serve a purpose to some users out there, hence why it’s in the repos, but for my own personal use, it doesn’t really do anything for me.

[scott@endeavourOS ~]$ sudo pacman -Rns eos-update-notifier
[sudo] password for scott: 
checking dependencies...

Package (1)          Old Version  Net Change

eos-update-notifier  1.14-2        -0.04 MiB

Total Removed Size:  0.04 MiB

:: Do you want to remove these packages? [Y/n] 
:: Processing package changes...
(1/1) removing eos-update-notifier                 [-----------------------] 100%
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Updating the desktop file MIME type cache...
[scott@endeavourOS ~]$ 

Goodbye for now my sweet update notifier, I barely knew you! :frog:

1 Like

Don’t forget to run the following (some steps might be unnecessary, I’m no longer sure, it was a while ago):

systemctl --user stop eos-update-notifier.timer
systemctl --user stop eos-update-notifier.service
systemctl --user disable eos-update-notifier.timer
rm ~/.config/systemd/user/eos-update-notifier.service
rm ~/.config/systemd/user/eos-update-notifier.timer

…to completely get rid of eos-update-notifier. Otherwise you’ll just get harmless but spam errors in your log files.

3 Likes

I don’t worry about it much either - I have my own information ‘sources’ withjout it - including a bash function for update counts, and another for update names (findable on this forum) which just give you information when you ASK for it :grin: Oh - and nicely formatted too (in the case of upls).

No downside to deactivating it, or to changing its frequency of appearance - and no way I can think of for it to be causing the problem! A hardware difficulty is far more likely, especially if hard poweroff has become a ‘thing’ and spinning drives are present…

1 Like

Consider it done :+1: (hopefully I did all these cmds correctly!):

[scott@endeavourOS ~]$ systemctl --user stop eos-update-notifier.timer
[scott@endeavourOS ~]$ systemctl --user stop eos-update-notifier.service
[scott@endeavourOS ~]$ systemctl --user disable eos-update-notifier.timer
Removed /home/scott/.config/systemd/user/timers.target.wants/eos-update-notifier.timer.
[scott@endeavourOS ~]$ rm ~/.config/systemd/user/eos-update-notifier.service
[scott@endeavourOS ~]$ rm ~/.config/systemd/user/eos-update-notifier.timer
[scott@endeavourOS ~]$ 

I don’t have any issues with the update notifier and I agree it’s most likely not the cause of any issues, I’m just merely removing it because I don’t really need it and I’ve honestly meant to remove it before, but just kept forgetting about it :wink:

1 Like

I have never had any issues with the update notifier either. I don’t think it has anything to do with the OP’s freezing issues. If it were me i would try the Nvidia 390xx drivers instead of nouveau.

3 Likes

Hey Guys, A lot of this is above my pay grade but very interesting. Can I thank you ALL :slightly_smiling_face: for well thought input - thanks
I think that I should have set 2nd previous log instead of the first to get you guys the correct information for freeze and powering off.
Having froze twice this evening I have now generated the 2nd previous log and web link…

https://clbin.com/zfpgV

I think this should give you guys the information you need :thinking:

I still think you should try the Nvidia 390xx drivers.

Edit: Your Bios is out of date. Latest version is A25 March 2018

2 Likes

Hey thanks Rick…

Bit confusing as on other Topics advice is that if you are having problems then try nouveau :thinking: Just for your information - all three computers are Nvidia and all use nouveau without even one problem. This Dell E6420 i7 is the latest or newest. Will try 390 driver if you still want me to - hope I can get back if not successfull :cold_sweat:

This is interesting - did not know this. Presumed EOS updates would have updated BIOS to latest available. Thought EOS delivered bleeding edge versions of everything - the opposite of Trisquel gnu-linux which just seems to deliver mainly security update patches between major releases?
Is there a “Discovery” item covering update BIOS…?
Just done update today and rebooted as advised, when I noticed Arch 250.1-1 where it used to say 250-4.
Thanks so much :ok_hand:

It does as far as it is provided from Arch repos.

If your machine is supported, fwupd is the package you need. Here is wiki article:

https://wiki.archlinux.org/title/Fwupd

1 Like