Forza Horizon 5 crashing or don't starting

Hi there,

I would be very grateful for any help.

I am trying to run Forza Horizon 5 on Steam through Provon without success. This is the same machine where I run, for example, No Man’s Sky, Dirt 5, Days Gone, etc, without issues.

But Forza Horizon 5 can’t run. Or the game crashes in that screen where first appears the image of a controller with a loading icon, or it does not even starts, depending of the Proton version I use.

I have already tried several Proton versions, including GE, without success.

I have a Core i7-7700HQ with 16GB of RAM, the game is installed in a SSD (Kingston), and I am running Endeavour OS already with driver 6.4.2.

Thanks in advance for any help.

P.S.: I forgot mentioning. This machine also has a Nvidia GTX 1060.

P.S. 2: now I got to run the game one time. But it crashed in just around 15 seconds of gameplay. I was not able to pass that introductory/tutorial part.

Did you check out the protondb page?

Yes, but I was not able to find anything helpful there. :frowning:

It s a shot in the dark, but try the different window modes in game settings. In Horizon Zero Dawn I can only play the game in borderless windowed mode. If I try any other graphic mode game freezes just like you describe. On top of that I have to reset to borderless windowed mode each time I play the game or it will freeze.

Thank you very much.

But, unfortunately, even doing this the game crashes after just a few seconds of gameplay. :frowning:

Even in a windowed mode. Moreover, FH5 does not haves such modes, you can only choose between full screen of not. But even moving to no full screen, it crashes. :frowning:

Do you run steam through a flatpak? or did you directly install it on your machine?

So, I installed Steam from my distro repos (multilib/steam

From my experience, games crashing or not launching in steam can usually be fixed by using the correct proton version. Based on what I see in ProtonDB, the game is rated as silver in terms of compatibility, so that means it should run but you might run into some issues.

What version of proton have you tried? Also, have you tried any game launch options?

I am running EOS with KDE, using the flatpak version of Steam along with the Proton 7.0-5 community build and it seems to work for me. I am also on an AMD GPU.

I would highly recommend to try and use the flatpak version, everything comes bundled including the dependencies so there is really not much to do.

1 Like

Hum, great suggestions. Thank you very much, @TheProf . :slight_smile:

Well, I tried Proton version GE 8.6, Experimental, 8.0.2, 7.0.6 and 6.3.8.

I will try all of those, including the Flatpak version. I just don’t know if I can run both at the same time.

You should be able to run both. The flatpak is isolated from the other dependencies so it should not interfere. Just make sure you are launching the flatpak version, you can do that from the terminal using flatpak run name_of_flatpak.

Great! Thank you so much.