Forcing Vsync externally

I need it this thread to force Vsync though my GPU panel. I have a low frame rate problem which fix is doing this.

I have nvidia modeset=1 done, but I don’t get any sign of synchronization, my panel looks like this:

Looking I found the Arch wiki pages of Prime and Optimus, which I don’t even think what I’m looking for. And from what I heard the process is a mess thanks to Nvidia. I don’t know how to force Vsync through the panel: where should I even look?

Edit: there is no screen tearing, the only problem is that frame rate is low.

Since you’re on KDE, it’s best to do via desktop environment settings:

Settings → Display and Monitor → Compositor → VSync

There are different modes available to balance between tear-free and performance, test and see which suits you best

2 Likes

Oh, and since you asked about nvidia specifically - you should press Advanced button near bottom of that screenshot, and then you’ll see 2 checkboxes:

image

Both should be checked to effectively use Nvidia’s VSync, however i strongly suggest against it and using just KDE’s settings, because they have much better performance especially in games…Those Nvidia settings will force it in most uncompressed way :sweat_smile:

2 Likes