[fixed upstream] Kwin closes unexpectedly

Every time I use the window effect on deepin desktop, the kwin closes unexpectedly. Also the windows and the bottom panel / dock are not translucent as they should be.

it is reported by others also that effects do not work, workaround is to install deepin-wm and uninstall deepin-kwin for the moment

and welcome at EndeavourOS, nice to sail with you!


I am also effected by this bug of deepin-kwin. Deepin-wm solved it temporarily.

not all effects will work after this, but mostly usable…
It will be a good idea to install LTS kernel and headers plus deepin-anything-dkms it can be that modules will brake on next update for you:
sudo pacman -S linux-lts linux-lts-headers deepin-anything-dkms

Downgrading the KDE dependecies worked for me. Though it’s only a temporary solution you can try this if you want deepin-kwin to work:

sudo pacman -S downgrade

downgrade "kactivities=5.74.0-1" "karchive=5.74.0-1" "kauth=5.74.0-1" "kbookmarks=5.74.0-1" "kcmutils=5.74.0-1" "kcodecs=5.74.0-1" "kcompletion=5.74.0-1" "kconfig=5.74.0-1" "kconfigwidgets=5.74.0-1" "kcoreaddons=5.74.0-1" "kcrash=5.74.0-1" "kdbusaddons=5.74.0-1" "kdeclarative=5.74.0-1" "kded=5.74.0-1" "kglobalaccel=5.74.0-1" "kguiaddons=5.74.0-1" "ki18n=5.74.0-1" "kiconthemes=5.74.0-1" "kidletime=5.74.0-1" "kio=5.74.0-1" "kirigami2=5.74.0-1" "kitemmodels=5.74.0-1" "kitemviews=5.74.0-1" "kjobwidgets=5.74.0-1" "knewstuff=5.74.0-1" "knotifications=5.74.0-1" "kpackage=5.74.0-1" "kservice=5.74.0-1" "ktextwidgets=5.74.0-1" "kwallet=5.74.0-1" "kwayland=5.74.0-1" "kwidgetsaddons=5.74.0-1" "kwindowsystem=5.74.0-1" "kxmlgui=5.74.0-1" "frameworkintegration=5.74.0-1" "networkmanager-qt=5.74.0-1" "plasma-framework=5.74.0-1" "kdecoration=5.19.5-1" "kscreenlocker=5.19.5-1" "kwayland-server=5.19.5-1" "kwin=5.19.5-2"

PS: Don’t use it if you also have KDE installed alongside.

The issue is tracked here: https://github.com/linuxdeepin/developer-center/issues/1945

1 Like

Works for me also :grinning:
however, panel is no longer rounded shape, it becomes square…

It has always been that way in version 20 Kwin.

Not used deepin in a while, went in the bin along with Winblows.

Deleting the kwin.rc file then rebooting used to fix this, or is it that far gone now :man_shrugging:

This issue seems to be fixed with the new deepin-kwin update.

i ćan confirm that here on a fresh vm install!