Firefox screen tearing or screen distortion on KDE

I think I noticed it two days ago, Firefox has this translucent stripe where the image distorts a bit.
To pinpoint the location, if you go to the main forum page, it is at the height underneath the menu where Categories, latest, new etc resides.
It is only visible with videos and scrolling pages and the best way to describe it is, for those who experienced the era, when you had a VHS videotape with a recording on it that has been played a lot through time, the video “rolled” through a stripe in certain areas.
My apologies to the younger audience who have no idea what I’m talking about, but it is the best way I could think of to describe it.
It looks exactly like that.

It isn’t the kernel or the hardware, because Vivaldi doesn’t have that issue. Is it something that can be manually fixed, or do I have to sit and wait for this one to be fixed?

If you minimize it’s window and then bring it back is it lost?

I just tried it and it is still there.

Then it’s probably not what i think it is…can you maybe picture it with phone?

I tried to record it, but it is hardly visible on the recording.

Are you still on KDE Plasma?

If so, what’s the value of?
Display and Monitor → Compositor → Tearing prevention (“vsync”)

Try to change it to full screen repaints, hit apply and see if it prevents that distortion


yes, still.

1 Like

OMG, that did the trick, thanks! Strange that Firefox only had the issue, though.

1 Like

Haven’t noticed this? My settings are on automatic. Is this on the Ryzen machine?

Not only it’s just fairly random effect, it’s sometimes caused by attempt of Kwin to do performance / quality tradeoff when value of vsync is “Re-Use screen content” or it’s chosen via “auto”, sometimes causing all kinds of bugs like parts of windows distorted or disappearing, or scroll cause extreme stutter :frowning_face:

For example, if i use picture in picture mode to view some video, sometimes if i drag or resize this pip window main Firefox windows will disappear completely until you somehow refresh it (by dragging again or minimizing ) :laughing:

So best way to prevent it is using one of the more hardcore and less performant vsync modes

1 Like

Yes, it was, but @keybreak explained it is random apparently and the issue “spared” Vivaldi. It’s a bit weird.

1 Like


btw, there’s one thing i wonder - what’s your GPU?
I have seen this on Nvidia (proprietary drivers), coz that’s the machine i’m spending most time on…Wonder if it’s maybe only Nvidia or something…

No, it uses the integrated Radeon vega that is shipped on Ryzen.
I do have an old HP tower with an old Nvidia Geforce 630 that uses the nvidia-470xx driver that serves as a multimedia player and TV in my bedroom and that one delivers a clean image.

1 Like

Ok, then probably it’s all-around random :laughing:


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.