Firefox remembers my download history even after disabling it!

I have disabled remember download history in firefox but still I can see my recent downloads in the firefox taskbar icon while right clicking on it. List gets cleared only after clicking forget recent files. How to fix this??

Check the Settings… button to the right

This is my default setting.

Hmm…So after that and reboot it doesn’t clean still? :thinking:

Yep the list stays until I click Forget Recent Files …

This setting only clears the list from the Firefox’s main interface (if you check the list under Downloads section, the items will be gone), but it will leave the list in the task bar jump list untouched. This design is silly and unintuitive in my opinion, but that’s just the way it is.

You can try to turn off the list altogether. Open up firefox, go to the address bar and type about:config and hit Enter. A warning will be displayed at this point, just ignore it and proceed. You will be redirected to a new page with its own search bar. Use that search bar to search for taskbar. Post a screenshot of the search results.

Okay. So it doesn’t seem like firefox is responsible for keeping track of the list. So let’s turn to your desktop environment next.

Can you head over to System Settings > Workspace Behavior?

Take a screenshot and show us what’s in there.

After your message, I was going thru the options on Workspace Behavior. Found the solution on Recent Files tab. When I clicked “Clear History” downloads list got cleared. Thanks @anthony93

Is it possible to disable it? :stuck_out_tongue:

I don’t use KDE, so I can’t be too sure. But I suppose you can try to select “for specific applications” if you need to remember history for some other applications. Firefox’s recent files won’t be saved as long as Firefox is not on the list.

Cool … I will tweak it around. Thanks once again :slight_smile:


System Settings > Workspace Behavior > Activities > Default > Configure Default Activity > Privacy (Tick Do not track usage for this activity) > OK


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.