Firefox not showing some icons on webpage

My favorite computer magazine uses special characters in some of their tables to show if something is good (+), very good (++), bad (-) or very bad (–). But these characters do not show in my firefox. It rather shows as missing characters:

Bildschirmfoto vom 2022-08-08 07-12-41

Here is in an example how that is supposed to look like. Picture from the print version:

2022-08-08 07.19.07

I am using gnome, firefox 103.0.1-1 and the noto fonts
noto-fonts 20220607-1
noto-fonts-emoji-apple 1:15.4-4
noto-fonts-extra 20220607-1

In the firefox fonts settings I allow a webpage to download its own fonts.

Any idea what I can do to fix this?

PS
This is the original table. But I am afraid you can only see that if you pay for it:

Maybe you can download this website as Html source and then share it here.

https://support.mozilla.org/en-US/questions/1026582 (icons not displaying)

And

https://support.mozilla.org/en-US/questions/1192208 (FF showing numbered squares)

:innocent:

@mbod
Do you use something like uBlock Origin, NoScript (etc) where downloading web fonts from the current site is disabled?

1 Like

run the following command and post the URL

pacman -Ql firefox | grep icons | eos-sendlog

I am using ublock origin but it is deactivated for the webserver www.heise.de

1 Like

https://clbin.com/AK2Uu

Will this help you out ?

image

But doing this is slightly doubtful to me… :thinking: :thinking:

looks good, errors from the system can be ruled out.

I tried it. But it did not help. security.sandbox.content.level was 4 initially. I changed it to 1 and restarted firefox. Dint help.

Here is the source code of that webpage: https://clbin.com/Fdwhb

The part which is shown in my screenshot (Funktionen ; Bedienung; Display; etc.) starts around line nr. 4067

When I open this source code file in firefox it looks a little weird, but the table is there and it shows the issue:

Bildschirmfoto vom 2022-08-08 16-57-23

Right click on one of broken icons → Inspect → Fonts tab to the right, what does it say?

Bildschirmfoto vom 2022-08-08 18-54-42

My guess is that site is created by complete idiots who expect pretty obscure font (for web) to be installed in order to display iconic characters, or else…So it’s problem with them, not with your system.

pacman -Qs adobe-source-sans

The website is running normally for me, as always. I would turn off all firefox plugins if available and see if it works. how does the website look in another browser?

heise_screen

First of all: Thank you very much. The problem is solved.

But it is not adobe-source-code, adobe-source-serif-fonts, adobe-source-sans-fonts or adobe-source-code-pro-fonts
None of them solved it.

But ttf-google-fonts-git did the trick. This a huge package with plenty of fonts and it conflicts with the mentioned adobe packages.

Anyways, its solved now. Thanks!

Bildschirmfoto vom 2022-08-08 19-25-57

2 Likes

Thats good to know. Which font packages do you have installed? May be I can get rid of this gigantic ttf-google-fonts-git package.

No problem, but…still it’s their fault, they should do it better way. either with standard ASCII characters that each font has or svg icons…so if you care about this site i’d write them some feedback in order not to install huge google fonts package :laughing:

I haven’t set anything on mine. this is a week old EndeauvourOS installation.

I installed adobe-source-code-pro-fonts which removed ttf-google-fonts-git and the website is broken again.

So adobe-source-code-pro-fonts on its own is not sufficient

adobe-source-code-pro-fonts 2.038ro+1.058it+1.018var-1