Fingerprint detection issue in GUI

I recently got a Dell 7630 with a fingerprint reader. And tried enabling the fingerprint detection in Endeavour.
I was able to follow the fingerprint-gui page in the arch wiki and this forum post to get fingerprint working in the TUI, and lightdm detecting it (but not recognizing) in the lock screen.

  • fingerprint-gui did not detect my sensor, but i was able to register with fprintd-verify
  • I am able to login in the TUI using my finger, but no such luck in lightdm

Did you add the line to your PAM config for LightDM?

auth    sufficient

Here is the relevant part of the wiki:

Yes, I have. Since then Ive also tried SDDM enabling via Arch Wiki, where its able to sense my fingerprint, but not authenticate it

Can you explain what you mean by that? It sounds like the fingerprint is failing validation, is that right?

I set up a fingerprint reader on an Arch box not too long ago using fprintd. It was really simple and works very well. If you can’t get fingerprint-gui working I would say give it a shot because it was very easy to set up:

So far everything for fingerprint is successful, except logging in. Ive tried LightDM and SDDM, both of which refuse to either acknowledge i have a finger, or that i have a sensor whever they please.
Though I have added the following to get it working everywhere except login managers:

auth		sufficient try_first_pass likeauth nullok
auth		sufficient

It does seem to work if i add those lines to the lightDM. But im not sure if that is the right approach

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.