File system error

i once dared to think i might use windows again and i never changed it back since than,

these outputs mean nothing to me, i know far to little to understand them.

I think what need to be done is to blacklist the uas module? But i’m guessing here.

What does this show?

lsusb

@AmandaONeill
I’m assuming it’s an external usb drive? What is the make of the drive? Seagate?

it does show all devices including the drive.

it is seagate indeed

Bus 002 Device 007: ID 0bc2:3343 Seagate RSS LLC desktop drive stgy8000400
Bus 002 Device 002: ID 04e8:61f5 Samsung Electronics Co., Ltd Portable SSD T5
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 005: ID 046d:c08b Logitech, Inc. G502 SE HERO Gaming Mouse
Bus 001 Device 004: ID 046d:c33f Logitech, Inc. G815 Mechanical Keyboard
Bus 001 Device 003: ID 045e:028e Microsoft Corp. Xbox360 Controller
Bus 001 Device 002: ID 12d1:1506 Huawei Technologies Co., Ltd. Modem/Networkcard
Bus 001 Device 007: ID 8087:0a2a Intel Corp. Bluetooth wireless interface
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I think it is incompatible with uas module? This is my guess based on info i’m looking up and the errors in the dmesg. Maybe @Stagger_Lee can help?

From your log:

[  236.704378] ntfs3: Unknown parameter 'windows_names'

[  387.186185] ntfs3: Unknown parameter 'windows_names'

[ 1947.595863] ntfs3: Unknown parameter 'windows_names'

[ 2023.519779] ntfs3: Unknown parameter 'windows_names'

[ 2230.550237] ntfs3: Unknown parameter 'windows_names'

This is mentioned in the Arch wiki page I linked to earlier; there is currently a bug with udisks2. A workaround is given:

udisks supports NTFS3, but has some issues at the moment. See udisks ntfs3 PR and issue 932.

As a workaround, add a such option to /etc/udisks2/mount_options.conf in [defaults] section:

ntfs_defaults=uid=$UID,gid=$GID,noatime,prealloc

2 Likes

I only have an example mount options conf file in that location

You can create the file.

For example, using nano:

sudo nano /etc/udisks2/mount_options.conf

Then paste this in it:

[defaults]
ntfs_defaults=uid=$UID,gid=$GID,noatime,prealloc
2 Likes

Beat me to it … :grin:

@Stagger_Lee
Did you look at the link i posted because supposedly there is an issue with seagate drive and the uas module also?

No, sorry, I’m a bit busy doing something else right now. But the message about windows_names that appears in the log is specifically mentioned in the Arch wiki, and there’s a link to the issue at the udisks2 github page, so I’d be leanng towards that.

1 Like

Yes it could be but the dmesg also has a lot of messages related to uas and dropping out off the usb connection causing read write errors? I don’t know? :man_shrugging:

Edit: Thanks for the help…

should i not use any specific UID or otherwise from the seagate drive? just this unaltered?
I just like to be absolutely certain of what i am doing, especially if it is regarding drives.

Yeah, maybe, I dunno. I’m kind of tied up on another forum at the moment, so I don’t have time to look at that right now.

1 Like

The sigil ($) should “automigically” work with any device you attach.

1 Like

Upon creating the file and putting the line in i still have the same problem. (even after a restart)

Well, maybe look into the uas issue that @ricklinux is talking about.

thats the thing again.
I sadly do not know what this acronym means. if it is one that is.

Can we see the file you created?

cat /etc/udisks2/mount_options.conf | eos-sendlog

as per the helpful instructions

https://clbin.com/35PhR