Failure to boot into Endeavour from a live USB

Forgive any lack of / poor terminology, I’m new to Linux.

I created a live USB of Endeavour using Rufus on my main driver so that I could dual boot it onto my laptop with Win10 on a separate partition. Freed up around 300GB on my disk, disabled secure boot control in the ASUS laptop’s UEFI, and set the USB as my first option to boot into.

Booted up, got to the pre-install screen (i.e. selecting proprietary or default drivers, EFI shell, and rebooting into firmware interface), chose default drivers, and ended up on this screen:

I had a similar issue when trying to install Manjaro on the same laptop, where it fails to find a device and gives the sh: can’t access tty; job control turned off message, except in Manjaro’s case it mentioned not being able to identify a specific UUID.

Any idea what keeps causing this or what I could do about it? I’ve booted Endeavour into a vm on my main driver and everything went perfectly, I don’t know why I get so much grief from my laptop?

Thank you and sorry if I explained the issue poorly.

Looks to me the ISO is broken (you got a corrupt download) or your USB stick is broken.
The error basically means it can’t find itself, aka it can’t find the stick you are booting from.

In that case it seems more likely that the USB is just broken considering the consistent error across different ISOs. I’ll try to find another one and hopefully that’ll help. I tried Ventoy as well as Rufus and both yielded the same result so I don’t think I made any mistakes in terms of making the live USB itself.

1 Like

If you use Rufus, make sure you write the iso in “DD” mode if it asks. I have seen weird errors if not.

Also current iso 27-8 is broken with rufus…things on there way balena etcher should work

1 Like

Heh, I missed that since I used Mintstick to make my new install stick.

(Weird that Rufus works worse than etcher btw; I have never gotten etcher to work properly but Rufus has always worked regardless of ISO. Not that I don’t believe you :slight_smile: )

I tried using Balena Etcher instead of Rufus and the outcome was having my USB somehow split into two separate drives, both unformatted and each requesting to be formatted. I tried plugging it into my laptop anyway on the possibility that Windows just couldn’t read it but it wasn’t even identified as a plugged in device in the BIOS so that didn’t work. I don’t think it’s an issue of Rufus not working with Endeavour considering that I had the same issue trying it with Manjaro. I have no idea why Etcher messed it up so badly but I returned the USB to its original state with diskpart.

Then I tried Rufus but writing the ISO in DD mode, and the result was, as before, an E: and F: “drive”, both unable to be viewed in Windows, and the USB itself doesn’t get identified in the UEFI of my laptop, so impossible to boot from. Upon trying to clean the USB in diskpart, the entire PC crashed (as I was writing this). I rebooted, noted that the two drives relating to the USB were gone, did what I was trying to do on diskpart again, and successfully cleared out the USB.

Back at square one. I don’t have any other USBs that can actually hold more than half a gigabyte so I can’t even test with a different one. Both Rufus (in DD mode) and Balena Etcher had the same effect as an end result, being two unformatted drives on the USB that can’t be recognised in BIOS and can crash my PC if I try to clean them. I have absolutely no idea why this is happening. The only thing I have left is to try making an Ubuntu live USB (something I’ve done with this stick in the past) and seeing if that works or if it gets screwed up too. If that also fails, I’ll know the USB is broken, or something? This is torture and I couldn’t even find anyone else experiencing a similar enough thing online (perhaps because I can’t even really wrap my head around what is actually going on) so don’t even have any obvious references to other people experiencing the same thing.

I have always used etcher on both Windows and Linux. Never a problem. I now use popsicle on linux. You may need to wipe that usb clean and format it to try again.

Edit: https://discovery.endeavouros.com/installation/create-install-media-usb-key/2021/03/

I solved one issue and arrived right back at the first again.

I used Etcher to make the live USB, the same issue took place in which it created another drive and spammed a “format drive” message from Windows for the two of the drives. I figured it had failed again and so I went to clear them with diskpart. Upon trying to clean the disk, my PC crashed (again). When I rebooted I only had one USB-related drive as opposed to the two from before. Instead of continuing to clear the drive, I decided to unplug it and try it on my laptop. This worked.

The BIOS was able to identify the USB and I was able to boot from that, at which point I proceeded to go through all of the installer’s steps to set it up. All fine, everything installed as I expected. The installation was complete, the GUI said “All Done.”, I shut down the laptop and unplugged the USB.

Rebooting brought me to the Endeavour GRUB. I loaded into the first option to get to the newly installed OS and the following error appears:

This was also the same error I had initially. It’s not that it isn’t recognising the USB, because that isn’t plugged in. I’m too much of a noob to be able to actually figure out what is wrong / what is being asked of me here.

It’s 1am where I am and I need to be up at 5am so I can’t proceed any longer right this moment, not that I’d have any idea what to do even if I did have the time.

1 Like

I see this is UEFI bios. Did you remove the secure boot keys before disabling secure boot.

My process for disabling secure boot consisted of going to Security>Secure Boot>Secure Boot Control and setting it to ‘Disabled’. I didn’t make a conscious effort to remove secure boot keys, no.

Might not hurt to remove them and go from there.

I was just thinking that this could be an issue with RAID system in use on the system, can you check this?
Showing output of this:
sudo fdisk -l | eos-sendlog
lsblk -f | eos-sendlog
what will create pastebins and gives you short url you can post here

or if you do not want that run commands without | eos-sendlog

Sorry for the radio silence - was moving.

I searched online for information regarding secure boot keys but do not know the implications of removing them or how to actually do so. If I do remove the keys should I then reinstall Endeavour or should I expect to be able to boot in to my pre-existing install?

Because the furthest I can get is the emergency shell I can’t run either of those commands. The only things I’ve figured out how to do are basic commands like pwd, ls, cd, etc, nothing using sudo permissions.

you can send from ISO live session…

I have the exact same issue right now, was it ever solved?

Hello @Folklore
Would you be able to post the link to inxi -Faz --no-host | eos-sendlog if you boot on the live usb.

As @joekamprad siad you can boot on the live ISO and supply us the info we need to help you. Post a link to this output.

inxi -Faz --no-host | eos-sendlog

Nevermind, I fixed this by using etcher instead of rufus. Rufus has some issues right now with EndeavourOS

In Arch have always had good experience of using imagewriter Drag and drop GUI, no options required.

If in Windows I use Rufus and write in DD. Arch, Arco or Endeavour does not boot unless I use DD.