Failed to start Load Kernel Modules on boot after system update (nvidia)

I updated my system and restarted it and got this error, I then tried to boot into the fallback initramfs and the same error occurred. Then the computer seems to freeze and not do anything and I have to turn it off. I think I have a backup on my drive with timeshift so I may need to use that. Any help would be appreciated, thank you. Also if I do have to use my timeshift backup (seems like I will), how can I know what caused the system to crash and why it will no longer boot to avoid causing the same problem again?

2 Likes

For now I am back in Windows :frowning: (on my other drive)


mod note: read here:


Same issue. I got my system to boot by rolling it back a week following this: https://wiki.archlinux.org/title/Arch_Linux_Archive#How_to_restore_all_packages_to_a_specific_date

I don’t know the actual fix unfortunately, but this should at least result in a working system for now, until an actual fix is posted/patched.

Probably not ideal to run older packages though, that’s your choice.

Just decided to try out Endeavour tonight and am getting the same issue. Installing offline gives a working desktop but installing online with the latest kernal hangs on startup.

Unfortunate timing I guess.

Edit: The online installer works now. KDE up and running. Thanks to everyone in the thread!

What kernel version? I upgraded this morning (about 12 hours ago) to the latest zen kernel (v5.19.3) without a hitch. My other (2) Arch-based VMs were also upgraded today.

Can you be more specific with the error?

Just updated this morning as well, am not able to boot.

Everything seems ok, but get no further than:

[ OK ] Mounted /boot/efi.

I’ll try to replicate it by upgrading again, is there any specific information that you want?

Before I do so, if this helps;
From my memory;
System upgrades as normal, updated to kernel 5.19.3-arch1-1
reboot
booting stops with 'Failed to load kernel modules"
I can still access tty so it’s not totally failed to boot
running systemctl status systemd-modules-load.service shows that ‘nvidia_uvm’, ‘vboxdrv’ and ‘vboxnetadp’ failed to load with the error “invalid argument”

Just did the update today and now my system won’t boot.

Says Failed to start Load Kernel Modules 3 times over. I am not an expert on troubleshooting Linux.

But my journalctl -b says
Systemd-modules-load: Failed to insert module “nvidia_uvm”: invalid argument.

So something wrong with Nvidia drivers or the kernel?

Any recommendations on reverting to a working system? Not familiar with any rollback mechanisms in Linux.

A heads up; i’m no expert, so this might be a bad way to get the system working again. I rolled my system back using this https://wiki.archlinux.org/title/Arch_Linux_Archive#How_to_restore_all_packages_to_a_specific_date

tl;dr:

comment out all the existing mirrors in /etc/pacman.d/mirrorlist

add the following to the same file;

Server=https://archive.archlinux.org/repos/[date]/$repo/os/$arch

where it says [date]; put the date you want to roll back to. I did 15 August 2022 but you can chose any date before the broken kernel update.
eg; Server=https://archive.archlinux.org/repos/2022/08/15/$repo/os/$arch

force an update with pacman -Syyuu
reboot

that got me back into a working system with the older packages. Whenever you want to try an update again just uncomment the mirrors in /etc/pacman.d/mirrorlist and remove the one you added.

3 Likes

Just created an account to confirm that i have the same issue when installing EndeavourOS on a new system with the latest ISO. Using an offline install works for now.

I just stumbled upon the same error. I rolled back kernel and headers, which seemed to work. However, now lightdm won’t start.

Five new users with the same problem creating accounts within a few hours. :thinking:

So where is the main thread? Reddit? It would be a good idea to link to it.

Welcome to the forum.

Also see this:
https://discovery.endeavouros.com/forum-log-tool-options/how-to-include-systemlogs-in-your-post/2021/03/

I use the amd kernel, last updated / last rebooted:

2022-08-23T09:29
Tue 23 Aug 22:37:41 BST 2022 

Outstanding updates:

babl-git 0.1.94.1.gacd0b86-1 -> 0.1.94.2.g626a9f5-1
bolt 0.9.2-1 -> 0.9.3-1
fastfetch-git r956.aa1237b-1 -> r957.952989c-1
firefox 103.0.2-1 -> 104.0-1
fsearch-git 0.2.r32.g5ebdfa8-1 -> 0.2.r35.g5e8d216-1
geoip-database 20220802-1 -> 20220823-1
gimp-git 2:48838.941a53dfbc-1 -> 2:48845.0ad54f863a-2
konsole-git 21.11.90.r571.gfc45802b7-1 -> 21.11.90.r573.g073d3f0e0-1
oh-my-zsh-git r6641.3668ec2a82-1 -> r6643.6d48309cd7-1
opera 90.0.4480.48-1 -> 90.0.4480.54-1
pahole 1.23-1 -> 1.24-1
sdl2 2.0.22-2 -> 2.24.0-1
sdl2_image 2.6.1-1 -> 2.6.2-1
sof-firmware 2.2-1 -> 2.2.1-1
vscodium 1.70.2.22230-2 -> 1.70.2.22230-3
x264 3:0.164.r3095.baee400-2 -> 3:0.164.r3095.baee400-4
xapian-core 1:1.4.19-2 -> 1:1.4.20-1

Now fully updated and rebooted, not seeing any errors or problems…

… thanks man … save a lot of time :+1:

Thanks, this worked! For the noobs:

  1. On the screen where you see the error, press control + alt + F3

  2. log in with your username and password

  3. cd /etc/pacman.d/

  4. make backup of your mirrorlist: sudo cp mirrorlist mirrorlist.bk

  5. open mirrorlist in editor: sudo nano mirrorlist

  6. put # in front of all lines which do not have it

  7. add lines at bottom and write Server=https://archive.archlinux.org/repos/2022/08/15/$repo/os/$arch in the second to last line
    image

  8. press control + x and confirm you want to write this to the file mirrorlist

  9. pacman -Syyuu (you need internet connection and my wifi did not work, so I needed to connect the ethernet cable)

Note that this will cut you off from updates. Once the issue is resolved, you need to copy back the backup mirrorlist (sudo cp /etc/pacman.d/mirrorlist.bk /etc/pacman.d/mirrorlist)

2 Likes

isn`t rolling back a bit drastic as a workaround ?
And is the real issue not nvidia-dkms package?

do you all run nvidia GPU and nvidia-dkms package is used?

on telegram users having this switching to the default non-dkms nvidia packages solves the issue …
Ctrl+Alt+F3 (to login into TTY)
sudo pacman -R nvidia-dkms
sudo pacman -Syu nvidia (or also nvidia-lts if LTS kernel is used)

And logs? my friends where the hell are the LOGS :person_in_lotus_position: :point_up_2: :grey_question: :grey_question: :grey_question: :grey_question: :grey_question: :grey_question:
journalctl -b -0 | eos-sendlog
inxi -Ga | eos-sendlog

7 Likes

Thank you sir! that nailed the issue down. I was using nvidia-dkms.
Installed regular nvidia driver and it boots fine now!

Also appreciate the rollback option as well was about to do that but saw this most recent update.

am noting down both these methods so i can troubleshoot better next time.

Thank you all for helping out. :slight_smile:

That’s very likely it. I’ll switch and activate the update when I have time. Could you elaborate how to post logs while being stuck at boot? Thanks

@joekamprad I have an RTX3070 and am not affected. What card is everybody affected using?

in this case it is not stuck it is only not able to start x system… so you can still log in to TTY via Ctrl+Alt+F3