Failed to start load kernel modules and /boot

Hi, i just updated my system with sudo pacman -Syu And after reboot i got this:

Idk if this helps or not, but i’m using legacy and mbr

Looks to me that it could not mount the /boot partition.

Is this your first reboot after install?
Do you have an USB stick connected still?
Are you sure your HDD / SDD is healthy?

no it’s not first reboot, i’ve installed it ~3 days ago and now it happened after updating my system

yes my SSD is fine, i can boot into windows and everything is normal

1 Like

My suggestion then would be to boot on the Endeavour install stick and repair the bootloader:

https://sangams.com.np/how-to-restore-reinstall-grub-bootloader-in-arch-linux/

I guess you could try chrooting to your installation from the live ISO, making sure your boot partition is mounted as well and then reinstall your kernels. Reinstall the bootloader as mentioned above for good measure. Please have a look at how-to chroot into your system here:

luckily i had arch livecd, im reinstalling grub and kernel through chroot and let you know the result

Reinstalled grub and made config, but in only recognizes windows10 on sda2 O_o
(My linux installed on sda3)

What about the kernels?

From your live ISO, please post the output of

sudo parted -l

efibootmgr -v

Make sure you have internet connection in your Live environment. Chroot int your system according to the instructions in the aforementioned link.

cat /etc/fstab

Update your system:
yay

Then run:
sudo mkinitcpio -P

Update Grub:
sudo grub-mkconfig -o /boot/grub/grub.cfg

You could login to your forum account from the live iso and post the outputs of the commands above.

kernel is fine(i guess?), its just bootloader problem now

parted -l

[root@archiso /]# parted -l
Model: ATA KINGSTON SUV400S (scsi)
Disk /dev/sda: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  608MB   607MB   primary  ntfs         boot
 2      608MB   52.8GB  52.2GB  primary  ntfs
 3      52.8GB  240GB   187GB   primary  ext4


Model: USB3.0 FLASH DRIVE (scsi)
Disk /dev/sdb: 31.1GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  31.1GB  31.1GB  primary  fat32        boot, lba

efibootmgr -v (im usin legacy/mbr so i dont think its helpful)

[root@archiso /]# efibootmgr -v
EFI variables are not supported on this system.

cat /etc/fstab

[root@archiso /]# cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
#UUID=4CD8CF1DD8CF03E4                     /boot          ntfs    defaults,noatime 0 2
UUID=5e63c1a9-6a70-47cf-9ba1-178376d28230 /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

mkinitcpio -P

[root@archiso /]# mkinitcpio -P
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> ERROR: specified kernel image does not exist: `/boot/vmlinuz-linux'
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> ERROR: specified kernel image does not exist: `/boot/vmlinuz-linux'
[root@archiso /]# 

grub-mkconfig

[root@archiso /]#  sudo grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found Windows 10 on /dev/sda1
Found Windows 10 on /dev/sda2
done
[root@archiso /]# 

It doesn’t look so.

I think you would need to reinstall your kernel again from a chroot environment:

sudo pacman -Syu linux linux-headers

If you get the same errors as above, Look at linux.preset in /etc/mkinitcpio.d. It should have the following content:

# mkinitcpio preset file for the 'linux' package

ALL_config="/etc/mkinitcpio.conf"
ALL_kver="/boot/vmlinuz-linux"

PRESETS=('default' 'fallback')

#default_config="/etc/mkinitcpio.conf"
default_image="/boot/initramfs-linux.img"
#default_options=""

#fallback_config="/etc/mkinitcpio.conf"
fallback_image="/boot/initramfs-linux-fallback.img"
fallback_options="-S autodetect"
1 Like

reinstalled as you said

this time :

[root@archiso mkinitcpio.d]# cat linux.preset 
# mkinitcpio preset file for the 'linux' package

ALL_config="/etc/mkinitcpio.conf"
ALL_kver="/boot/vmlinuz-linux"

PRESETS=('default' 'fallback')

#default_config="/etc/mkinitcpio.conf"
default_image="/boot/initramfs-linux.img"
#default_options=""

#fallback_config="/etc/mkinitcpio.conf"
fallback_image="/boot/initramfs-linux-fallback.img"
fallback_options="-S autodetect"

after this , tried to make new config but still the same, no linux in grub

Could you run and post the output of:
sudo os-prober
from chroot.
?

And also please post the command line you have used for reinstalling the bootloader.

[root@archiso mkinitcpio.d]# os-prober 
/dev/sda1:Windows 10:Windows:chain
/dev/sda2:Windows 10:Windows1:chain

installed grub and bootloader with arch wiki help
install grub package, then grub-install --target=i386-pc /dev/sda
and after that sudo grub-mkconfig -o /boot/grub/grub.cfg

Your commands look right to me. I am not sure what is lacking.

You didn’t get the errors as before after re-installing the kernel? ( as in the output of the mkinitcpio -P that you posted before).

What says:

ls /boot

?

no, i can do it again if u want

[root@archiso mkinitcpio.d]# ls /boot
grub  grub.bak  initramfs-linux-fallback.img  initramfs-linux.img  vmlinuz-linux

I don’t think you need to re-run it again. The images seem all to be in there. To be honest, I fail to see what might be lacking.

Do you mind waiting for other more advanced forumers to chime in and look at this with fresh eyes?

Can Windows see a Linux boot entry?

Boot into Windows and

  1. Run CMD (run as administrator)
  2. type bcdedit /enum firmware

You should get a list of all possible boot options including network boots etc. And of course any Linux ones.

thank you for you help, it meant much too me

also , i tried to create a custom entry in 40_custom but didnt work :smiley: so yea i will wait abit more.
and tbh, i can reinstall it again since i clean installed 3 days ago and havent done much customizing

2 Likes
Microsoft Windows [Version 10.0.19042.508]
(c) 2020 Microsoft Corporation. All rights reserved.

C:\Windows\system32>bcdedit.exe /enum firmware

Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  partition=E:
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {current}
resumeobject            {4aa7e3be-af11-11eb-8ec7-8ef7591e632b}
displayorder            {current}
                        {4aa7e3c2-af11-11eb-8ec7-8ef7591e632b}
toolsdisplayorder       {memdiag}
timeout                 30
1 Like

a question, is it possible to remove grub completely and make an entry with EasyBCD since im usin mbr?