Failed to start Light Display Manager

Happy late Easter everybody :slight_smile:

I’m facing a slight issue. Whenever I try to boot from the linux-lts kernel my system doesn’t start the x-server. I always get the following message: [FAILED] Failed to start Light Display Manager

Surprisingly everything works well on the normal kernel…

Here’s my x-org log: https://dpaste.com/BS9U9G8GB

Any help would be appreciated…

Thanks :wink:

Update: Just booted my system with the lts-kernel out of curiosity… and it worked this time…
It’s seems like it’s a mixed bag… sometimes it works and then other times it throws the above mentioned error…

Hope that future updates will fix this issue :+1:

Some additional pointers:

journalctl -u lightdm may show more/other information.

[   390.174] (WW) Warning, couldn't open module intel
[   390.174] (EE) Failed to load module "intel" (module does not exist, 0)

Perhaps try removing xf86-video-intel if it is installed.

1 Like

Thanks for replying!

I don’t have the xf86-video-intel installed as it caused problems in the past.
As for the journalctl log - here you go: https://dpaste.com/87JKH7LZN

Could this weird behavior be tied to the recent mesa update? Saw a lot of posts where people encountered the same problem :thinking:

Thanks again!

Do you have logind-check-graphical=true inside of lightdm.conf? This might help from it happening.

Hm. Not much in there except that it fails to start. Check the logs under /var/log/lightdm/ .

Hmm… I never changed anything in that config file except the session greeter. Mine is set to lightdm-mini-greeter.

Looks fine to me… There aren’t any errors in that file…

Anyways, thank you for your help : )

OK, time for the Arch wiki:

https://wiki.archlinux.org/index.php/LightDM#Troubleshooting

Thank you. I will take a look at it tomorrow :slight_smile:

Hi again,

I tried your solution yesterday and it seems that this setting fixed my issue.

Thanks for your time and help :wink:

Sorry to reopen this…

After some time my initial solution stopped working. I just can’t wrap my head around why this is still happening.

I looked into the X.org log file and the only thing that makes sense to me is the last couple of lines…

(EE) no screens found (EE)

Do I have to specify my screen in the lightdm config?

Thanks everybody for your help :wink:

Assuming this still holds:

Then why are you not just using the normal kernel?

If the problem persists, might be worth trying another display manager, e.g. sddm as a workaround.