External sound card stand-by (power saving?)

Hello everyone!
I would like to ask you for help. I am a newbie and I apologize if the problem has already been discussed but I have not found anything about it.
I have been using EndeavourOS for a few months with satisfaction on my laptop and recently I thought about installing it on my desktop PC too.
Everything works wonderfully but an annoying defect compromises the pleasure of using the system: I have an external Focusrite sound card that turns on and off constantly, generating bumps and strange rustles. It seems that the card turns on only when it has to generate a sound and turns off a few seconds later as if it were going to stand-by.
The fact would not even bother me if everything happened in silence but the noises caused by these continuous switching on and off are unbearable.
I specify that I have encountered the same problem on Manjaro and Arch while this does not occur on Ubuntu-based distro. I thought of a setting in the kernel present on Arch and derivatives, a kind of power saving of the sound card.
I tried to find a solution to disable it but to no avail. Would anyone know how to help me?
Thank you very much, bye!


Welcome :slight_smile:

Yes, that’s powersaving check this out

That’s not healthy for device / speakers so it’s better to get rid of this powersaving for your card :slight_smile:

Some usb audiocards detected automatically and doesn’t turn off, sometimes you have to set it manually for some models

I had a similar issue with an external USB DAC that I posted here a few days ago. That 2nd solution worked for me, which is to prevent PulseAudio from going to sleep.


Thanks everyone for the tips!
As soon as possible, I will try again to install EndeavourOS on my desktop pc and I will do as you advised me.
I’ll let you know, bye thanks!