External HDMI monitor no signal after the screen is turned off and on

I have an Acer Predator 17 laptop that has a gtx 1060. Connecting the laptop to an external 4K monitor via a HDMI cable. It seems to work for the most part but when I turn off the external 4K monitor via the power button then turn it back on, the screen shows no signal. The only way to get to come back up is on the extended monitor turn off the external display and turn it back on. Is there something I need to configure to get it to stay like this even if the external monitor is turned off?

Edit 1: I am using XFCE desktop and a Lenovo 4K monitor if that matters.

Did you install the Nvidia drivers? I’m assuming this laptop has hybrid graphics. Intel/Nvidia. Does it have hybrid setting in the UEFI Bios?

Edit: inxi -Faz --no-host | eos-sendlog

I don’t think this laptop has hybrid graphics.

System:    Kernel: 5.15.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-linux-zen root=UUID=f5edb123-9101-41e9-8cda-0d995bc1ecc8 rw quiet
           resume=UUID=99a38426-14ad-48d3-9d7b-edd597f1d434 loglevel=3 nowatchdog
           Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 dm: LightDM 1.30.0 Distro: EndeavourOS
           base: Arch Linux
Machine:   Type: Laptop System: Acer product: Predator G5-793 v: V1.14 serial: <filter> Chassis: type: 10 serial: <filter>
           Mobo: Acer model: Challenger2C_SKS v: V1.14 serial: <filter> UEFI: Insyde v: 1.14 date: 03/02/2018
Battery:   ID-1: BAT0 charge: 75.1 Wh (100.0%) condition: 75.1/90.0 Wh (83.4%) volts: 17.0 min: 14.8 model: AS15B3N
           type: Li-ion serial: N/A status: Full
CPU:       Info: Quad Core model: Intel Core i7-6700HQ bits: 64 type: MT MCP arch: Skylake-S family: 6 model-id: 5E (94)
           stepping: 3 microcode: EA cache: L2: 6 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41599
           Speed: 2900 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 2900 2: 2801 3: 2857 4: 2874 5: 2836 6: 2846 7: 2848
           8: 2851
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort mitigation: TSX disabled
Graphics:  Device-1: NVIDIA GP106BM [GeForce GTX 1060 Mobile 6GB] vendor: Acer Incorporated ALI driver: nvidia v: 495.44
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c60 class-ID: 0300
           Device-2: Realtek HD WebCam type: USB driver: uvcvideo bus-ID: 1-9:3 chip-ID: 0bda:57f3 class-ID: 0e02
           serial: <filter>
           Display: x11 server: X.org 1.21.1.1 compositor: xfwm4 v: 4.16.1 driver: loaded: nvidia
           resolution: <missing: xdpyinfo>
           OpenGL: renderer: NVIDIA GeForce GTX 1060/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44 direct render: Yes
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel
           v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0403
           Device-2: NVIDIA GP106 High Definition Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
           bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.40 running: no
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Rivet Networks driver: ath10k_pci
           v: kernel bus-ID: 06:00.0 chip-ID: 168c:003e class-ID: 0280
           IF: wlan0 state: up mac: <filter>
           Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Acer Incorporated ALI driver: alx v: kernel
           port: 3000 bus-ID: 0b:00.0 chip-ID: 1969:e0a1 class-ID: 0200
           IF: enp11s0 state: down mac: <filter>
Bluetooth: Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb v: 0.8 bus-ID: 1-7:2 chip-ID: 0cf3:e300
           class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends

Your right it only has dedicated graphics nvidia. That’s a bonus as less problems.

When you say the only way to turn it back on is turn off external display and turn it back on. What do you mean? Is that different than turning off the monitor power?

Yes when I click on the slider next to the monitor drop down box on the right here (to the left first to disable, then to the right again to reenable), it forces XFCE to reconnect the external monitor and it works again. Also another way to get it to work again is to unplug the HDMI cable and replug it to force XFCE to recognize it as well. However when I press the power button on the monitor and turn the power back on it will show No Signal message on the monitor. I can’t tell if this is a specific monitor issue or an XFCE issue.

Do you have any of the settings set in advanced for the external display?

Yes just the following default setting so I can turn off the monitor on the laptop itself and use the external monitor as primary. I have tried both with and without profiles, it does the same thing. So I’m thinking there is something else at play here that I am missing.

Do you have the laptop monitor set as primary display?

Edit: I’m just trying to understand how you turn off the primary display and then set to use the external?
Did you try setting the laptop as primary?

Neither of them are set as a primary display. I tried setting the external monitor as primary monitor as well, then turned it off, and on to try. It still gives a No Signal after it comes back on.

Did you try setting the laptop screen as primary?

I can’t set the laptop display to primary when it is disabled.

What i mean is normally you would have the laptop working and set as primary on the laptop display. Then you would hook up an external monitor and set it up to either be mirrored or not and you can use xrandr to set display settings and resolution if it’s different.

Edit: https://docs.xfce.org/xfce/xfce4-settings/display

Could be both. HDMI can be a bit finicky, and Xfce might not know how to handle it.

Sometimes it comes down to how the DE handles a monitor disconnection. HDMI-connected displays can disconnect completely when they power off, which means the PC will remove the output from the display configuration. Then, when the output powers on, the DE isn’t configured to use it.

Pulling the cable and re-inserting forces an electronics-level reset, which is why the laptop detects it again.

Yes I followed that page to setup this external monitor. At this point I’m thinking its the monitor that’s giving me these issues. Even if it works fine in windoze.

This, is a very good explanation on what I am experiencing right now. It doesn’t look like turning on the monitor sends a electronics-level reset to the laptop thus giving a No Signal message when its powered back on. My laptop also has DisplayPort output but I don’t seem to have a cable to connect it from the laptop to the monitor. This might be something else to try.

It might be worth trying a GNOME live image to see if that handles the disconnection. If it does, it’s Xfce. If not, it’s the monitor.

Like @jonathon say’s it’s probably the HDMI port because when you turn off the monitor it’s not detecting a signal so it shuts down because the detection comes from the laptop not the monitor. So turning the monitor back on it doesn’t sense a signal because it’s not looking for it. :thinking:

Edit: I think maybe some monitors keep power on to that HDMI port so this doesn’t happen?

I will try the DisplayPort Connector. I have ordered a cable. I will update here when I get to test it tomorrow. HDMI seems wonky here.

1 Like

That’s a good idea. It may be different. :thinking: