Evolution keeps asking for keyring password

I am trying Evolution mail client, but it keeps asking for keyring passwords everytime I start it. How can I just do it once so that it stops asking over and over again ?

I have checked https://wiki.archlinux.org/index.php/GNOME/Evolution#Using_Evolution_Outside_Of_Gnome, but is seems complicated to me what and how I need to do it.

Use seahorse and set a blank password. I don’t know if that’s a bad thing to do, though.

edit:
Or try the link below and create a default keyring.

Which DE are you using?

What have you already tried from that wiki page?

I am using XFCE, I tried with Seahorse, but now it keeps asking to add mail account password to keyring and seems not adding it, or not working.

There’s a setting (Settings -> Session and Startup -> Advanced -> Load GNOME services at startup) which starts GNOME services on login - check that box and the keyring should start working.

4 Likes

Yes, that works, thanks.

1 Like

May I ask you where I can find these settings in Mate? I got nearly the same problem. Evolution asks for the email account password every start of the program.

MATE will load GNOME services by default, just make sure you have gnome-keyring installed (and that the password for you Login keyring matches your actual login password).

After installing seahorse, the two passwords of my email accounts were saved after the next start of evolution and entering them. I don´t really understand why. Seahorse is just a gui for the keyring. Gnome-keyring and Gnome-keyring-daemon was already installed and in the Autostart list. It´s magic. Thanks for your reply

1 Like

Weird. Seahorse by itself doesn’t do anything, I would guess that it brought something else in as a dependency…

$ pactree -d1 seahorse
seahorse
├─gtk3
├─gcr
├─libsecret
├─libsoup
├─gpgme
├─gnome-keyring provides org.freedesktop.secrets
├─libpwquality
└─libhandy0
1 Like