Ethernet Problem After New Installation

Hello guys, I’m new and I’m finally approaching EndevourOs.
Sorry if I get the terminology wrong.
I installed Endevour in dual boot with windows 10.
During the installation several times the live version of Endeavor failed to connect with ethernet, sometimes it was detected and sometimes not. It worked perfectly via usb.
After installation it sometimes connects and sometimes it doesn’t. When it doesn’t go I restart the pc hoping it will go.
Before i write this post i read a lot of similar issue here and all talk about the problem of realtek driver.
I’m using the realtek driver r8169 and i’ve never installed the r8168.
I found this in the Arch documentation and i don’t know if its relevant for my case.
Realtek no link / WOL problem (3.3)
My hardware is : msi gaming blus b550 , ryzen 5 5600x and a nvidia 2080s.
I’m new and i didn’t install the driver for the motherboard because i didn’t found how to do it, i don’t know if maybe this is the problem, also i didn’t install any other driver except for the gpu(i use nvidia-inst command).
lscpi -v command return this for my ethernet controller :

2a:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

  • Subsystem: Micro-Star International Co., Ltd. [MSI] Device 7c56*
  • Flags: bus master, fast devsel, latency 0, IRQ 34, IOMMU group 15*
  • I/O ports at f000 [size=256]*
  • Memory at fc504000 (64-bit, non-prefetchable) [size=4K]*
  • Memory at fc500000 (64-bit, non-prefetchable) [size=16K]*
  • Capabilities: *
  • Kernel driver in use: r8169*
  • Kernel modules: r8169*

sorry for the inconvenience, thanks in any case

If your device shows it’s r8168 (and NOT) r8169 the solution seems to lie near.


Most likely you just need to install the r8168 package. You may need to blacklist the r8169 module but it may work without having to do that also. I would just try it with the r8168 and see first.

 sudo pacman -S r8168 
 sudo modprobe r8168 

See if that works for you.

Since you dual-boot with Windows, don’t forget to disable the “Fast Startup” mode. It can hold on to the NIC even when Windows seems to be shut down. It is enabled by default, and it is not obvious how to turn it off:


tried but nothing changed, now it works without the fast startup mode in windows.

Update *
Not working anymore after change the fast startup mode

After disable the windows option for the fast startup mode ethernet seems to work but after the first reboot stop working.
I tried installing the driver r8168 and nothing changed. I did

sudo pacman -S r8168 
sudo modprobe r8168 

This is the result of the comand lcspi -vv :
2a:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
Subsystem: Micro-Star International Co., Ltd. [MSI] Device 7c56
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 34
IOMMU group: 15
Region 0: I/O ports at f000 [size=256]
Region 2: Memory at fc504000 (64-bit, non-prefetchable) [size=4K]
Region 4: Memory at fc500000 (64-bit, non-prefetchable) [size=16K]
Kernel driver in use: r8168
Kernel modules: r8169, r8168
After that i reboot and stil not working, i tried to blacklist the r8169. I create the file /etc/modprobe.d/blacklist.conf and add the line blacklist r8169.
Still not working. What can i do ?

Check if you get a different result starting the system from a cold boot (as opposed to a reboot).

I did it.
I have noticed some strange behavior. Sometimes work and after a reboot still work. But sometimes not.
With a cold boot seems equal.
I did 3 cold boot at the first wasn’t warking but after a reboot work. In the other 2 cold boot the ethernet work perfectly on the first shot .
I don’t know. Ethernet is perfectly working i tried it in other distro and in windows and work perfectly.
I don’t know why i have this strange issue.

It is the chipset, not the driver. When shutting down Windows, the NIC is turned off, and the linux driver doesn’t know how to turn it back on… this has been reported all over the net (e.g. see here, here, and also in the link you provided in your OP).

Perhaps, get a new ethernet device, or just use wifi and see if it helps.

What is the other distro you tested, and what kernel is it running? That might be a good clue; testing other kernels could be helpful in general.

Is there any difference between booting while the device is plugged in versus running on battery?

I tried PopOs with kernel 6.0.12 and ubuntu wich i don’t remember but it works.
Im in a desktop setup, i can’t unplugged the battery.

So getting a different pci-ethernet card would NOT cost much.

Forgot the important word above.

this probably is the last option ahahah

Okay so you disabled the fast start up feature in Windows which is in power management correct? Not the fast startup in the Bios although you can also disable that if it has it also. I would try again with the r8169 module. So make sure r8169 is not blacklisted and uninstall the r8168 package. Then reboot and see if it works.

unfortunately I don’t have a WiFi antenna.
Probably u are right and the problem are caused by windows that turn of the nic when is shut down.
I read the link u send and i disable the option Shutdown Wake On Lan and the things seems to work for now. I’ll wait few days and check if it works.

1 Like

yeah i disable the fast startup option inside windows. I sure give a try at your suggestion and see what will happen. How can i see if the r8169 is blacklisted? I just deleted the file i created /etc/modprobe.d/blacklist.conf , that’s enough?

1 Like

Yes you remove the file and uninstall the r8168 package to see if it now works on the r8169 kernel module. Most of these ethernet do but some work on the r8168. I would only use the r8168 if you prove it doesn’t work on the r8169 kernel module but does in fact work on r8168 instead.

I open my pc rn and ethernet not workd anymore. I’m going crazy, it’s so random…

I wanted to try but the ethernet didn’t go when I turned on to try and now I’m still with the r8168 and r8169 blacklisted drivers. Being that it still doesn’t work I tried uninstalling the r8168 and removing the blacklist but still nothing.

summarizing what i did until now is

  • Remove from windows the fast startup mode
  • Disable the Shutdown Wake On lan Option as said in this page and in documentation
  • By default i was using the r8169 driver with the same result, still work but randomly stop working some times, i switch to the r8168 driver but nothing changed, same issue.

i will try the other option in the arch documentation like

  • Enable LAN Boot ROM in BIOS/CMOS
  • Enabling IOMMU

Other ideas?