Error when try to install pamac

Helo, finaly i install new version of this OS but when i try to install pamac i have this error

Found CMake: NO
Run-time dependency appstream-glib found: NO (tried pkgconfig)

../src/meson.build:8:0: ERROR: Dependency "appstream-glib" not found, tried pkgconfig

A full log can be found at /home/yuli/.cache/yay/libpamac-full/src/libpamac-11.3.1/builddir/meson-logs/meson-log.txt
==> ERROR: A failure occurred in build().
    Aborting...

Which version of pamac are you trying to install?

yay pamac-all

Just to answer you (though I am not sure it will work), try:

yay -Syu pamac

But first before doing it, answer me why do you really want pamac?

 Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 endeavouros is up to date
:: Starting full system upgrade...
 there is nothing to do
:: Searching databases for updates...
:: Searching AUR for updates...
 -> Could not find all required packages:
        pamac (Target)

If pamac fails again you may want to try and give pacseek a shot.

I see it is outdated!

pamac-all 10.3.0-5 (+32 0.91) (Out-of-date: 2022-04-09)

I see pamac-aur is available!
But still @Omurtak didn’t answer me why he needs pamac?!
I have been there in my distrohopping, but thanks to EndeavourOS I find yay much easier!

pamac-aur doesn’t include support for flatpaks or snaps if that is important.

before i used pamac because looks very comfortable when i have graphic installer for the apps but if not support in the new OS no probllemjust good to know

pamac has some serious issues outside of manjaro. It is often broken because it targets the Manjaro repos which have packages at different levels.

That being said, you are welcome to install it if you would like.

Other graphical alternatives include octopi and bauh

thank you ill try to use more konsole for install then

1 Like

I have been in your place, but after my exxperience distrohopping for almost a year where most have graphic installers I found using:

yay -Syu application_name

much easier and faster.

For example you may try to install chromium browser (the open source chrome browser)

yay -Syu chromium

uninstall it simply by

yay -Rc chromium

Update all your system and installed software:

yay -Syu

Search for an app by name (example pamac)

yay pamac

Or search for chromium

yay chromium

Much easier and faster. (I think)

thank you , i also tryed to uninstall some apps which come with installation like Dragon Player but when i try to uninstall like this yay -Rc Dragon Player error: target not found: Dragon error: target not found: Player -> exit status 1

You need to use the package name

yay -Rc dragon

thank you :beer: :beer: :beer:

1 Like

If you’re going to use pamac (big if), I tend to recommend pamac-nosnap, which includes flatpak support. Never had trouble compiling that one. But unless you really need flatpak support, I’d use pacseek as @fbodymechanic suggested. It runs in a console window but you can still fully drive it with a mouse if you want. It’s not an “official” package yet but it’s maintained by someone on these forums so help is very available. Plus pamac has some problems compiling AUR packages, it doesn’t always know when to ask for input or give meaningful errors. pacseek on the other hand, just calls yay at the console.

1 Like

thanks for the info

1 Like