Error message when updating packages

whenever i run pacman -Syu i get this response about linux-lts

:: Running kernel-install for kernel 5.15.91-1-lts
/etc/os-release: line 1: Linux: command not found

idk what’s wrong :confused:

my uname -r results in:


That is the latest lts kernel. I don’t know what you are expecting? The lts kernel doesn’t update like the standard current kernel does. It will get changed when it is updated to the next lts kernel. People normally use the lts kernel because they want stability being that it doesn’t change often and is meant for long term support. If you want it to be updated you would need to install the current standard kernel along with the standard current headers.

Can you show the contents of file /etc/os-release?

I’m not expecting it to update, I use lts on purpose. The thing here is this error message that never happened before

Okay i didn’t get that is what you meant. The topic say’s kernel not updating.

Edit: If you can post what @manuel has asked for. He will be better to answer that.

i edited the title, sorry, english is not my first language and i was fishing for words

about /etc/os-release well, this is awkward because yes i do use arch (btw) and i asked here because arch community is not that much welcoming

NAME=Arch Linux
1 Like

probably the syntax was wrong

Variable assignment values must be enclosed in double or single quotes if they include spaces, semicolons or other special characters outside of A–Z, a–z, 0–9.


try the following changes:

NAME="Arch Linux"
PRETTY_NAME="Arch Linux"

it worked, thank you so so much :blush:

1 Like

This is not the original upstream package.
Actually, this is a link to /usr/lib/os-release, which is provided by filesystem package.
Have you edited this file yourself, or do you have any alpm/pacman hook that modifies it?

You should find out the real reason this happened.
This file is used/sourced from various system scripts, that usually run as root, thus, any wrong values (like in your current issue) might become potentially dangerous.

Tip: kernel-install was sourcing the file, and tried to run a command named Linux with root/sudo privileges. Luckily, that command did not exist…

1 Like

Actually, the Arch community is very welcoming, they just don’t like to be deceived.

So, it’s a good thing you didn’t ask there, because it is against their rules to ask questions if you haven’t installed your system the Arch way. The fact you are using an EndeavourOS install with the /etc/os-release/ edited to look like Arch certainly disqualifies you from asking questions over there, and they would certainly be in the right to ban you if you did.

Nothing wrong with that, it’s your system you can do with it whatever you want – just don’t say the Arch community is not welcoming, because that’s unfair towards them.

I’m pretty sure the OP already knows the real reason this happened. :wink:


is it a war crime to do a dirty install? how the hell is deceiving to revert all packages from endeavour repo back to arch and saying i don’t use endeavour anymore? “the arch way” broke my system enough times for me to give up and i had indeed asked for help with the grub mess and all post-installation settings and they were absolutely not welcoming. i thought people here would be, but well, not what i’m getting in this topic only

that’s gross. never thought i would run into arch gatekeepers outside of arch forums and only because of a small pacman trouble

sorry for asking for help i guess?

I think you are misunderstanding Kresimir’s post.

1 Like

I literally told you there is nothing wrong with doing that:


However, it is wrong to pretend you are using vanilla Arch on the Arch forums when you’re using a pre-configured install and calling them unwelcoming when you get caught and banned.

Even you know that this lack of transparency when asking for help is wrong. Proof:

The Arch forum has a good reason for this rule – the whole point of using Arch is to configure it yourself. There is a million ways to do it, but when you do it yourself, you know what you did, you are familiar with your OS. However, if you use a third-party installer like EndeavourOS, which can do that for you without you having to know what it did, asking Arch forum for help just wastes their time. They are 100% right to get upset with people who do that.

Not only that, but if they discover you are using EndeavourOS specifically, that creates bad reputation for EndeavourOS in the upstream community. It looks like we are sending our noobs to them, which is exactly what we are trying to prevent. The correct place to get support for EndeavourOS is the EndeavourOS forum, even if you’ve renamed your EndeavourOS install to Arch (btw).

This is not the Arch forum being unwelcoming, but rather users of pre-configured installs not being familiar with their systems, but feeling entitled for support on the Arch forum.

Well, you did get your problem solved, so there is no need to be upset. :slight_smile:




Arch forum will punish you accordingly!!111


the thing here is that i only said I use arch when it came up in the file, my problem was - so I thought - related to pacman updater and I had no idea it was because of that, and suddenly you started being condescending to me for editing my files

either way, im grateful for the person who helped me.

No, that is not what happened. I understand why it would feel that way to you, because of some inferiority complex of not using “real” Arch, but it has nothing to do with reality. For more info, please consult this thread:

Now, what actually happened is that I took issue with you calling the Arch community unwelcoming. The Arch community is a great one. I’ve never had any problems with them, quite the contrary, I’ve had nothing but good experiences there. Why? Because I followed their rules and never tried to deceive them.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.