Error: GPGME error: No data - new

error: GPGME error: No data error: failed to synchronize all databases (unexpected error)

I am getting the above errors and tried the following.

Nothing works

  • eos -rankmirrors

  • sudo pacman -Syyu

  • sudo rm -r /var/lib/pacman/sync/

  • sudo pacman -Syu

  • sudo cp -f “/etc/pacman.conf” “/etc/pacman.conf.orig”

  • sudo sed -i ‘s/SigLevel.*/SigLevel = Never/’ /etc/pacman.conf

  • sudo pacman -Syy gnupg archlinux-keyring endeavouros-keyring

  • sudo mv -f “/etc/pacman.conf.orig” “/etc/pacman.conf”

  • sudo pacman -Syu

still getting
error: GPGME error: No data error: failed to synchronize all databases (unexpected error)

Please help.

This error looks similar to the two below threads:

  2. Update problem (GPME error: No data) - #7 by ringo

Check them out.

Thanks for your reply.

I tried both.

still not working.

You could try this command:

eos-update --keyrings-reset

Edit: note that I wouldn’t recommend playing with SigLevel values.


I am getting eos-update: unrecognized option '--keyrings-reset'.

OK, you probably have an older version of package eos-bash-shared.
Instead you can run commands

sudo mv /etc/pacman.d/gnupg /root/pacman-key.bak
sudo pacman-key --init
sudo pacman-key --populate archlinux endeavouros
sudo pacman -Syy --noconfirm archlinux-keyring endeavouros-keyring
sudo pacman -Syu

error: GPME error: No data
while running the below command.

sudo pacman -Syy --noconfirm archlinux-keyring endeavouros-keyring

Have you tried sudo pacman-key --refresh-keys

I tried sudo pacman-key --refresh-keys now.

It didn’t solved.

@manuel and @ricklinux Does the OP maybe need to fully delete the EndeavourOS repo manually and then go through the process of re-adding it instead?

Maybe. There seems to be something quite broken stuff in the system.

Can you please show the output of command

eos-sendlog < /etc/pacman.conf

eos-sendlog < /etc/pacman.conf

Are you using ARM?

Are you asking about system processor?

Not ARM.

It is Intel-I7.

You could try installing the keyring packages manually.

sudo pacman -U
sudo pacman -U

and then try updating again.

error: GPGME error: No data


Did you already try deleting all files from /var/lib/pacman/sync/ ?

Edit: if this does not help, you can try commenting out the [endeavouros] repo lines from /etc/pacman.conf.

Also, better backup your personal data to an external drive, just in case.

Did you already try deleting all files from /var/lib/pacman/sync/ ?
Yes with sudo rm -r /var/lib/pacman/sync/

Does it help anything when downloading the packages first, and then install, something like:

cd /tmp
sudo pacman -U archlinux-keyring-20240429-1-any.pkg.tar.zst

and the same for the other package?

If that doesn’t work, I’m starting to run out of ideas…

Edit: your mirrorlist(s) might not work…
Edit2: have you checked the disk has enough space?

Do check the system time of this computer. Compare it with a mobile. It should be within a second or so.

A faulty clock can play games with signature checks.

Could also be a faulty disk area.