[Error] EndeavourOS Installation failed


I think this information isn’t relevant but anyway, i had manjaro kde installed before.

How did you partition?

Partition table was MBR. 512MB /boot 50GB / 350GB /home 8GB swap.

You should get a log with more information also other than that error popup. Also you can try to refresh mirrors before starting the installer, often that’s the problem.

It appears you have done a legacy install on efi. Is the device really old and not uefi compatable?

The installer is looking for a /boot/efi partition which you have not created.

Prior to this I have installed Ubuntu, Manjaro, Garuda, PopOS and i3 EndeavourOS. And they all were installed without an error. I created the same 512mb partion for them too with fat32 file system and /boot flag.

Right I found something. Package manager error in online install (offline is failing too)

I am having the same problem as this guy. People are suggesting to uncheck that hwinfo~ish package at the time of installation. I will try to do that once I am home.

Have you updated pacman mirrors before to launch the EndeavourOS installer ? I had a hard time with EOS install today because i tried to install it without updating mirrors (actual iso is a bit old…).

1 Like

No I did not.
I just tried unchecking that hwinfo~ish package and the installation was a success.

But there is one thing that is bugging me that is at the time of installation the calamares installer said something like “Your device is not compatible with EOS although it might get successfully installed but some features might not work for you” this is the first time some linux installer has said this type of thing to me. although the installation is working good right now but I am not too sure as not a lot time has passed yet after I have done the installation.

But there is one thing i have a list of pacman packages that i wanted to install but pacman was not willing to install the packages from that list it was only checking packages that are already installed I tried this multiple times with multiple ways but the end result was same, in the end I had to type every package name seperately for it to install them.
Commands that I tried
cat pacman_pkgs | xargs sudo pacman -S --needed
cat pacman_pkgs | sudo pacman -S --needed -
sudo pacman -S --needed - < pacman_pkgs
I also tried above commands without --needed tag
the package containing list was something like this
screenfetch
htop
alacritty
kitty

Please look if this is that “feature might not work” thing that calamares was talking about or just a linux command line rookie mistake.

@BONK please read my above message and tell should I redo my installation with a new flash drive or is every thing good. I need to hear from a Pro like you that “everything looks okay, you are good to go” so my mind will stop bugging me and I will have a good sleep. thank you

no need for

We have user_pkglist option for you to install a list of packages:
on live session before starting installer simply edit the file in liveusers home called user_pkglist put in only the list of packages no command is needed to be added.

And if you were trying to run this pacman commands from live session how they should work for you at all? the would only install the packages for the current livesession. ?

the command to install from a given packages list on installed system would be that:
pacman -Sy --needed --noconfirm - < /path/to/pkglistfile

1 Like

And if you were trying to run this pacman commands from live session how they should work for you at all? the would only install the packages for the current livesession. ?

No, I was installing pkgs with in installed system.

the command to install from a given packages list on installed system would be that:
pacman -Sy --needed --noconfirm - < /path/to/pkglistfile

Hmm…:thinking: This command it actually worked

But I have used these commands in the past

cat pacman_pkgs | xargs sudo pacman -S --needed
cat pacman_pkgs | sudo pacman -S --needed -
sudo pacman -S --needed - < pacman_pkgs

and they also have worked as expected only this time they did not worked. Also your command looks similar to mine except that y and --noconfirm tag.

Anyway thank you for these replies they have helped me. Also I will take above reply as your word that I don’t need to redo my endevourOS installation.

-y will reload package database and yea --noconfirm will not ask for confirmation.
I see also that due to pacman changes some commands for pkglists do not work on changes from time to time… and pacman do not like whitespace in the list file:
2021-12-03_14-08
will fail if there are such…

Here’s my log, for the same thing: https://termbin.com/l08w

I would not say your issue is the exactly the same… if you do to wanted to install extra packages from a packages list?

 Exit code: 1 (no output) 
2022-01-21 - 15:07:54 [2]: WARNING: [PYTHON JOB]: "Command 'pacman' returned non-zero exit status 1."

the error is caused by failing to fetch packages… which is in most cases an issue with failing mirrors or a very slow connection.

And in 99% of cases you can sole it by manually rank a mirror list before start install from welcome app.
And make sure to add nearby countries, and if you are in countries like India Pakistan or somewhere with only very little amount of available mirrors it is known to be working by adding US and German mirrors to the list. (checking these countries in addition).

If your issue persist after try this… open a new post and do not use old ones where no one get a notification…

closing