Error crypto disk not found on startup


I’m fairly new, been using Endeavour for a few months. Upon boot after the linux 3 choices screen I get a brief error about crypto disk not found, press any key to continue. Then my boot up is fine and normal. Anyway to get rid of this error, its just a minor annoyance. I have a luks crypto password on turning the machine on. I assume its for my linux drive. I also have a mounted(that starts unmounted) sd card.

Other than that Endeavour is great, I spend more time on it than my windows machine which is more powerful.

1 Like

I too have started to see this error upon startup.

  `Booting Arch Linux Linux, with linux-lts'
error: no such cryptodisk found, perhaps a needed disk or cryptodisk module is not loaded.
Loading Linux linux-lts ...
Loading initial ramdisk ...
Press any key to continue...

The boot process will proceed automatically without user interaction after a couple of seconds. But still, it’s annoying.

I have no idea when and why this behavior first occurred; I don’t boot very often.
Will try to figure out what is happening…

1 Like

yes i see the same on an old legacy Bios system too and users reporting this on telegram… i would like to know too…

Does it have anything to do with the UUID in /etc/crypttab :thinking:

1 Like

we need to find out… it could be calamares does some settings causing it…

as I once said, never encrypt a hard drive, it is your time and your risk doing so, … make sure
the bios has the right hard drive boot order, when you have more than one HD, UEFI or cable select section has a selection
from which the system boots. ( hard drive priority selection ), maybe that is the issue because the linux bootloader can not see it in such a case ?

yes i do only have one encrypted install here… that is the notebook I use on traveling… not that it has many personal data on it but in case it helps a bit to not be able to use any of my accounts on the web…
And w simply try to find the reason for the error shows up now… not discussing the pro and contras on encryption in general :wink:

1 Like

I’ve also started recently facing this issue as well!

Out of the blue, when I start my machine, I get a “Cryptodisk not found on startup” error which goes after I either press a key or wait a couple seconds!

But, in addition, it seems that my CPU usage has also suddenly significantly increased as well!

I’ve read that EndeavourOS has a bug where LUKS will massively increase the load and usage of your CPU until it has been properly unlocked!

I know with 100% certainty that my computing habits have not changed and my device (a Lenovo laptop) is relatively new (just got it about 6 or so months ago)!

So I was wondering if anyone else who’s device is now facing this new LUKS issue has experienced or noticed a notable increase in CPU usage for that particular device!

It’s gotten to the point where my laptop will have the fans running even when it’s just the system running with no applications whatsoever - This never happened before this new LUKS issue!

once LUKS containments are open the performance is not significantly more as without encryption used.
CPU load will be caused by something else.
You could check by monitoring with glances from terminal while the load happens… but better open a new thread to resolve the issue.

I know this is effectively a +1 with no more useful info but I have the same cryptodisk error and also a definite increase in CPU usage since the error started.

1 Like

Thank you for your response!

I knew I couldn’t be the only one experiencing a notable increase in CPU usage after this new cryptodisk error started!

I’ve already monitored my system using btop and found the culprit programs/processes to be dunst, picom, and xorg!

They are each now using a significant part of my CPU load when, before this cryptodisk error, they were never even in the top 20 of programs/processes in terms of CPU load/usage!

Personally, I suspect that this heavy CPU usage problem and this new cryptodisk error are related!

Therefore, I want to hold back on creating a new thread about this CPU usage problem until this crpytodisk error problem is fully resolved!

you are right as long as we do not know what is causing the error there is no way to make sure it is not related too.

But picom is also just updated per example and now adding itself to autostart which can cause issues if you was may using a custom starter before …

this is the only hint we got so far …

searching for the error text gave me only issues where system was not booting after the message.
and users landing in grub rescue shell…

# <name>               <device>                         <password> <options>
luks-2534 UUID=2534     /crypto_keyfile.bin luks
luks-ad11 UUID=ad11     /crypto_keyfile.bin luks
NAME                                          FSTYPE      FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
├─sda1                                        crypto_LUKS 1           2534                
│ └─luks-2534 btrfs                   5c2a   64,2G    36% /var/log
│                                                                                                                         /var/cache
│                                                                                                                         /home
│                                                                                                                         /
├─sda2                                        crypto_LUKS 1           ad11                
│ └─luks-ad11 swap        1     swap  c109                [SWAP]

uuids replaced :wink:

Could this be an issue with the mkinitcpio-openswap hook?


  • Is this only happen on BTRFS filesystem?
  • is mkinitcpio-openswap installed?

I just install fresh in a vm and it shows exactly the same error on boot …
BTRFS and swap-partition with hibernation…

SO this is officially a BUG now…

on ext4 it is not showing up…
i got only this after updating system to latest from offline install:

NAME   FSTYPE   FSVER     LABEL      UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
├─sda1 vfat     FAT32                DB4C-77D3                             298,9M     0% /boot/efi
├─sda2 crypto_L 1                    8654f669-f30f-4440-a7db-8bf67d96d8fa                
│ └─luks-8654f669-f30f-4440-a7db-8bf67d96d8fa
│      ext4     1.0                  7af87ca4-7d48-4084-b9b8-5de297e46d8c    6,7G    41% /
└─sda3 crypto_L 1                    6e71322b-58e8-43f5-af9b-3e177142ebd1                
       swap     1         swap       3a5f884d-a324-4e81-9546-9d6f2d9f59ba                [SWAP]
sr0    iso9660  Joliet Ex EOS_202209 2022-09-10-10-51-40-00 
1 Like
  • Is this only happen on BTRFS filesystem?

Perhaps, I’m using BTRFS on my system!

Also, I think it would be safe to assume that only a minority of EndeavorOS users have chosen BTRFS over EXT4!

Thus logically, if this was happening on non-BTRFS systems, this issue would probably be a lot more popular and gain significantly more traction!

  • is mkinitcpio-openswap installed?

I don’t have this program installed on my device but I do have its dependency, mkinitcpio, installed!

CORRECTION: I do actually have mkinitcpio-openswap installed on my system and it’s been installed for a while!

I am using ext4. The same error also occurs under this file system!

1 Like

What is your GPU?

Thanks for letting us know vincent!

By chance do you have mkinitcpio-openswap installed?

My GPU is AMD ATI 02:000.0 Renoir - AMD Radeon!

Also, it seems that my high CPU usage issue is an on and off again issue!

Right now, my CPU is running normally and the three problematic packages I mentioned (Xorg, Picom, and Dunst) aren’t using a significant amount of CPU power!