Crypto disk startup


I am having a similar problem to that which is solved in this forum post.

However, in my boot folder I don’t have a have any efi folder. A ls of my boot folder shows the following. Therefore the command used doesn’t work.

/boot🔒 ❯ ls
grub initramfs-linux.img  vmlinuz-linux
initramfs-linux-fallback.img  intel-ucode.img

What adjustments should be made to the command used so it would work?

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS


I guess, perhaps your installation is not in UEFI mode but in BIOS/Legacy/MBR mode?

What does

test -d /sys/firmware/efi && echo uefi || echo bios


If it is a BIOS mode installation:

1 Like

Yes it says bios.


1 Like

Please refer to the link posted above and adapt the command line to your actual disk.

Yes after checking out the link I used the bios command.

grub-install --target=i386-pc /dev/sdX

Using for the X the disk not partition that has grub. This I found using lsblk --fs.
Then I used the make config command grub-mkconfig -o /boot/grub/grub.cfg. I rebooted and all was ok.


Glad you got it resolved!
Please consider marking the thread as solved by checking the solution box under the actual post pointing out the solution.

:enos_flag: :wave:t5:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.