Error after uninstalling NoMachine

Hello, I installed NoMachine using yay, and it functioned smoothly without any issues. However, upon attempting to uninstall it (even through yay), the removal process appeared successful. Yet, whenever I attempt any action in the console, the following error message persists: ‘ERROR: object ‘/usr/NX/lib/’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.’

This error occurs consistently for every command I execute. Interestingly, when I switch to the root account using ‘sudo su,’ the error not appear anymore (only when using the root account). Unsetting LD_PRELOAD eliminates the error temporarily but it’s not a permanent solution. I could add this unset command to my .bashrc, but I’d prefer to eradicate the root cause of the issue.

I appreciate any assistance with resolving this matter!

What command did you use to remove NoMachine?

Also, take a look at this link. Seems very close to your issue.

I did yay -R nomachine
Anyway I restarted my computer and now the graphic interface don’t boot :frowning:. I‘m restoring the System with a previous snapshot

That would match with the issue listed at 3.7 “Graphical issues (especially with Wayland) after uninstalling NoMachine” of that link

Thank for the help, but now the problem is different. I use systemd and with a live cd i restored the system with TimeShift snapshot. Now when i try to boot the system it give me “Failed to mount /efi”.
I tried to boot into live cd, mount the linux partition and executed arch-chroot. After this i did reinstall-kernels. All worked but error on mount efi still persists.

EDIT: Fixed, thanks to chikenf00t and [SOLVED] Failed to mount /efi due to timeshift restore, I restored the system with a TimeShift snapshot, and solved the error by using a live cd of endeavouros, mounting the linux partition in /mnt and the efi partion in /mnt/efi, then I did “sudo reinstall-kernels” and all worked correctly.

1 Like

Welp, I guess that works too :sweat_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.