[SOLVED] Failed to mount /efi due to timeshift restore

Hello linux noob here, recently my plasma network configurations stopped working, and i didn’t wanna deal with it so i used timeshift to restore the system but when it finished i can only boot into emergency mode, when booting everything is green except for:
[Failed] failed to mount /efi
[Depend] dependency failed for local file systems
i saw similar problems that mention needing to boot into live environment and mount and chroot, i have no idea how to do any of that, and i’m afraid of breaking my system, so if it’s not too inconvenient for you, i’d really appreciate it if you could walk me through the process of doing that. Thank you in advance

Hello @Elaina and welcome to EnOS’ community!

Please boot up your live usb and post the output of the following command:

sudo parted -l

for some reason i couldn’t upload it directly to this forum

Hi @Elaina, here is a document which explains step-by-step how to chroot from the live environment:


Since you are using systemd-boot, when you restore a snapshot with Timeshift it will not roll back the kernel and initramfs with the rest of the system (because they are on the EFI partition). It is possible that is your issue. If so, you can just bring your system up to date from the chroot and that may be all you need to do.


i get errors

it seems that the terminal is offline somehow despite me sending this from the live usb, when i use ping command it says ping: google.com: Temporary failure in name resolution

You will have to connect to your WiFi network from within the live environment in order to use the internet.

the live environment was connected to the internet, just not the terminal when i chrooted, im on windows now, if i boot back to eos-live do i have to redo the mounting or is updating the final step to fixing my system?

Ah, I see now I misunderstood what you were saying–you had logged in to the forum from the live environment, but couldn’t use the network from the terminal.

If you need to take another try at getting the system updated because of the network thing, you’ll have to redo the whole process with the mounting and chrooting I’m afraid.

If you get back into the chroot and the network is not resolving again, take a look at /etc/resolv.conf and make sure it is set to use a nameserver that makes sense. Go ahead and paste it into the thread if you are not sure.

cat /etc/resolv.conf

You could try restarting NetworkManager from inside the chroot, or just manually edit /etc/resolv.conf and stick in a known good nameserver just for the sake of taking down the updates.

sudo nano /etc/resolv.conf

Save and exit, test if you can resolve a ping, then try taking down the update.

okay so when i went ahead to redo the steps from yesterday the terminal when i chrooted still had access to internet which was interesting, while it did give some warnings when i ran eos-update i am now texting from EOS and it works fine, so thank you so much for the help, thanks to pebcak too, one final question, what other tool or maybe timeshift setting i can use to backup everything and won’t cause me problems when restoring

The type of restoration you are trying to do will work much better if you use the Grub bootloader instead of systemd-boot, because you will be able to store your kernels and initramfs images on a Btrfs partition and include them in your snapshots. The choice between these bootloaders is presented in the installer, so you could just reinstall and choose Grub this time.

Or, you can try your luck switching bootloaders on the installation you have as was done in this thread:

1 Like

After restoring, before you reboot your system, make sure to reinstall your kernels:

sudo reinstall-kernels

This should build the kernel images from the snapshot you have restored and place them in your ESP and thus avoiding the issue that you have had.

i see, thanks i’ll consider it

oof i already rebooted without doing that

You are fine now.

Mine was just a comment as to what should be done when restoring a Btrfs-systemd-boot from a snapshot for not running into the issue that you were having.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.