Epson printer not compatible

Hello,
I just installed EndeavourOS, and I discovered that my printer (an EPSON XP-2100) isn’t compatible with CUPS. Is there any other solution ? Is a windows 10 VM a good idea ? I only have 8gb of RAM.
I have been a linux user for a few years, but never setup a printer (nor with windows).
Thanks in advance

there is linux drivers:
http://download.ebz.epson.net/dsc/search/01/search/searchModule

https://aur.archlinux.org/packages/epson-printer-utility/
https://aur.archlinux.org/packages/epson-inkjet-printer-escpr2/

1 Like

If you ever get a new printer HP has some of the best support in Linux in my experience :+1:

There are no drivers available for Arch-based distros

I tried installing this package, but it took a long time to compile, and I had to stop it. I rerun it, and it’s been like this for ~15mn, is it normal ?

It can be and depends on system specs and mirrors.

I don’t understand what did you mean by “a”
And about system specs, what helps speeding up ? I have an SSD. Also it’s only compilation taking time, not downloading, do mirrors have to do with compilation ?

can take a while to compile … never tried that one… but seems epson printer needs the epson app in addition to the driver i linked you …

Typo thank you for correcting me. Processor speed and number of cores. How many cores you have set to be used for the build process and amount of memory are all factors. Download speeds effect how long it takes to fetch the packages to build. As for the ssd that is the one thing that has the least to do with it.

Thanks for the explanation :smiley:
I don’t know how many cores I have set to be used during build. How can I check that ?

What is the apps you’re talking about ? I haven’t found it, and it does seems the printer utility requires it.
I tried launching the utility, and it outputs
Communication daemon down, Error code = -1

https://aur.archlinux.org/packages/epson-inkjet-printer-escpr contains the driver for the Epson Expression Home XP-2100.

1 Like

this is the official epson printer utility (application)

And @axt is right:

This driver package includes the driver for the XP-2100 …

And try installing as it should work with Cups, as it depends on cups :wink: and copies the drivers in the cups dir…
If this makes printer available in printer settings you do not nee the epson application.

1 Like

needs the systemd service started/enabled:
2021-09-19_22-29

A post was split to a new topic: EPSON ET-2750 incompatible?