Eos-update-notifier not working

After a problem i have i reinstall the EndeavourOS using the latest ISO and installed Plasma desktop. But i notice that the eos update notifier it does not notify me about any updates. Is there something else to do?

It is possible that there are no updates…

Can you show the output of terminal commands

    pacman -Q eos-update-notifier
    eos-update-notifier -show-timer

If there are no updates, it will show it on the terminal, as well as a small window telling the same thing.

If i run the
eos-update-notifier -show-timer
it shows this screen

You could run command

    eos-update-notifier -conf

and click either “OK” or “Set to defaults” button.

Is the timer active after that?

OK, seems that the timer was corrupted for some reason, but now it is active. :slight_smile:

1 Like

Thanks for the help

You’re welcome! :smile:

Do you want to know a little secret?.. @manuel is the Flash… :zap:( the super hero)


Oh its Friday night… so it is OK to have a drink after a hard week of work. :wink:


Take as many as you like, you need it to stay warm…

1 Like

As a matter of fact, I already had one… but that’s it for me. :slight_smile:

1 Like

I too have a problem with a not-working update notifier.

systemctl --user status eos-update-notifier.timer
● eos-update-notifier.timer - Run EOS update notifier a few times a day
Loaded: loaded (/home/theodis/.config/systemd/user/eos-update-notifier.tim>
Active: active (waiting) since Sat 2019-12-07 11:23:04 CET; 1min 52s ago
Trigger: Sat 2019-12-07 12:13:00 CET; 48min left
Triggers: ● eos-update-notifier.service

so everything fine here.
I set it to default but still no notifications about updates, even when there are definitely some in the pipeline.

kind regards,

It might be caused by an issue with the lock file of the update notifier.
You can check if there is this issue by running eos-update-notifier on the terminal.
It may complain about the lockfile already checking for updates.

Anyway, I fixed that issue already today. The new version is 0.7-9.


Indeed it does.
Thanks for the update. :slightly_smiling_face:

1 Like

hot to fix eos update? .png dont find

…just received the update

simple remove this files… we have them before copied to system, no we ship them inside a package:

sudo rm /usr/share/endeavouros/EndeavourOS-icon.png
sudo rm /usr/share/endeavouros/EndeavourOS-logo.png
sudo rm /usr/share/endeavouros/splash.png

then do updating again will work!


done. thx :sunglasses:

sorry for the inconvenience :grimacing:

Or in command line: sudo pacman -Syyu --overwrite=*